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Adobe Photoshop Lightroom – Best Practices

First let me preface this document by stating that I am fully aware that there is no single perfect workflow that will meet the needs of every 

educator, photographer and image maker out there.  Therefore it is critical that the tools we use are flexible enough to allow us to handle many 

different situations.  Fortunately for us, Lightroom has this flexibility.  What I am going to propose below is a workflow that I have found works 

well in “real world” environments for numerous photo educators as well as professional photographers.  It is, however, merely an outline, a series 

of suggestions provided to help you start thinking of how and when to incorporate the critical steps necessary for a successful and profitable 

photographic workflow.  It is my intention that these “best practices” will help you (and your students) to efficiently organize, edit, develop 

and output images while simultaneously completing assignments and meeting deadlines.  I fully expect (and encourage you) to customize 

these steps to meet your individual (and intuition’s) needs.  Even if you add, delete or rearrange steps, you’ll find Lightroom flexible enough 

to handle almost any scenario.  The necessary features and commands are available throughout the application and are always accessible as 

you move swiftly through your workflow. 

Before we begin, it is necessary to make  the following assumptions:

1) Students will use digital cameras, and capture images in the camera manufacturer’s raw file format which will be converted to DNG upon 

import into Lightroom.  (For advantages to working with DNG, please see Importing Files below.)  If capturing in the raw format is not pos-

sible, then files may be captured digitally and saved as JPEG or recorded on film and then scanned.  Regardless of the file’s format or origin, 

any changes made to the file’s metadata as well as any image corrections that are made in Lightroom will be nondestructive.

2) Files (including, but not limited to photographs) can be stored on individual student laptops, portable drives CD, DVD, or on a server. 

3) Individual student catalogs (also known as Lightroom’s database files) can be stored on any drive OTHER than a network drive (i.e. they 

can be backed up to a server, but they can not be run from the server).

With that out of the way,  lets get started.  The first step is to establish and create an organizational file structure for images, catalogs and other 

necessary files.  Students will begin by copying their files from their cards (or directly from their cameras) to their storage area (this might be 

a laptop, portable hard drive or server space) into an organized file structure schema.  Although Lightroom can import directly from a card, I 

prefer to copy my files manually to the hard drive.  Then, as I import them into Lightroom, I copy and convert to DNG in one step (please see 

the section on Importing for more information).  I have illustrated the organizational file structure that I have found to work on the next page. 

Obviously, the exact folder structure can vary, the key point is that it needs to be intuitive and, once established, it must remain consistent. 
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Julieanne Kost - this is the top level folder for each student, appropriately named the student name or ID number.

	 Original Images - this will include all photographs and duplicate backups.

		  Assignment01 - each assignment should have it’s own folder.

			   RAW Images - these are the original images and serve as a backup for the student (subfolders optional).

				    Image001.crw - these are the camera manufacturer’s original proprietary raw images.

				    Image002.crw - (etc.)

			   DNG Images - these are the files that are copied and converted to DNG when imported into Lightroom.

				    Image001.dng 

				    Image002.dng - (etc.)

			   Exported Images -these are the files to be submitted for the assignment.

				    Assignment01_JKost - this is the folder containing the images submitted for assignment 01.

					     Image001.dng - changes made to the file are stored within (no need for sidecar files).

					     Image023.dng - (etc.)

		  Assignment02 - each assignment should have it’s own folder.

			   RAW Images - these are the original images and serve as a backup for the student (subfolders optional).

				    Image081.crw - these are the camera manufacturer’s original proprietary raw images.

				    Image082.crw - (etc.)

			   DNG Images - these are the files that are copied and converted to DNG when imported into Lightroom.

				    Image081.dng

				    Image082.dng - (etc.)

			   Exported Images -these are the files to be submitted for the assignment.

				    Assignment02_JKost - this is the folder containing the images submitted for assignment 02.

					     Image081.dng - changes made to the file are stored within (no need for sidecar files).

					     Image093.dng - (etc.)

	 LR Catalogs - this includes all catalogs that the student creates.

		  Class Assignments - this folder contains the catalog organizing the student work for this course.

			   Assignments.lrcat - this database file is created by LR and contains of ratings, keywords, collections etc..

			   AssignmentsPreviews.lrdata - this database file is created by LR and contains cached previews.

			   Lightroom Settings - this folder (and subfolders) is created by LR to store user-created templates / presets.

		  Personal Work - this catalog is for additional images, personal work and could also include assignment work).

			   PersonalWork.lrcat - this database file is created by LR and contains of ratings, keywords, collections etc.

			   PersonalWorkPreviews.lrdata - this database file is created by LR and contains cached previews.

			   Lightroom Settings - this folder (and subfolders) is created by LR to store user-created templates / presets.

	 Miscellaneous Folder - this folder is for any additional documents.

		  Text documents - such as written lesson objectives, supplemental documentation etc.

		  Photoshop documents - such as logos to be used as identity plates or background images for slide show etc.

Organizational File Structure
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Lightroom Preferences

There are three settings which may help you to use Lightroom to it’s fullest potential in a shared lab environment.  On the Macintosh, the 

preferences are found under the Lightroom menu, on Windows, the preferences are found under the Edit menu.  Note - these settings don’t 

necessarily need to be changed if students are working from their own laptop.

• Preferences > General > Default Catalog.  For the option “When starting up use this catalog” choose “Prompt me when starting Lightroom”.  

On launch, Lightroom will display a dialog allowing students to choose a catalog to use (as opposed to automatically launching the last 

catalog used on that workstation).  If this setting is not changed, students can always choose File > Open Catalog or File > Open Recent 

to open the desired catalog. Note: this is also the way to switch from one catalog to another.

• Preferences > General > Catalog Settings, or File > Catalog Settings.  Both of these commands will display the Catalog Settings dialog. 

Choose General > Backup > Back Up Catalog and select “Every time Lightroom starts”.  This will create a backup of the catalog which, in 

my opinion, is always a good idea.  The backup might use a little disk space, but it’s well worth the investment just in case something 

happens to the primary catalog.

• Preferences > Presets > Store Presets with Catalog.   This allows any user-created setting such as metadata templates, develop presets 

etc. to be stored with the associated catalog instead of in the default location.  For students that share computers, the advantage is that 

they won’t have to see all of the other students presets.  However, if the student has their own laptop, then saving to the default location 

(not choosing this option) will make their templates and presets automatically accessible to all catalogs.  Note: the default location for the 

Lightroom Catalog and therefore it’s setting is:

	 Macintosh - (user) > Pictures > Lightroom > Photos 

	 Windows - (user) > My Documents > My Pictures > Lightroom 

Importing Files (Library Module)

While importing files into Lightroom, I take advantage of the opportunity to organize, copy and convert camera manufacturer’s proprietary 

raw files into the publicly documented, archival Digital Negative (DNG) file format as well as apply specific metadata information.  Requiring 

that students convert to and work with the DNG format has the following advantages:

1) Ability to quickly toggle on and off all changes made to an original image including (but not limited to) changes to exposure, color balance 

and saturation, sharpening, noise and lens correction to confirm that students are learning how to properly capture images “in-camera”.

2) Assurance that there was no selective manipulation of areas (i.e no removal of objects, no retouching of a model etc.).

3) Management of a single file - because all metadata can be saved within a DNG file (EXIF, IPTC, develop settings, etc.), there is no need 

to manage both the camera manufacturer’s proprietary raw file and a its corresponding sidecar file (xmp). 

Before importing files, choose Preferences > Import > Import DNG Creation and set the options to the following:

	 File Extension 		  dng,

	 JPEG Preview		  Medium Size

	 Image Conversion Method	 Preserve Raw Image

	 Options 			   Compressed (lossless) (checked on)

Then choose File > Import (or click the Import button at the bottom left of the Library module). In the Import dialog, select the following:

• File Handling > Copy Photos as Digital Negative (DNG) and Import  - this will copy and convert the original camera manufacturer’s pro-

prietary raw files into the DNG format and import the DNG files into Lightroom.  

• Copy To - click Choose to select the destination folder for the soon-to-be converted DNG Files (see the illustration on page 2 for a recom-

mended organizational file structure)

• Organize - choose Into one folder (otherwise Lightroom will create a duplicate folder structure based on the original files which is 

unnecessary and can be confusing when viewed in the Folders panel the Library module.)
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• File naming - You are more than welcome to rename your files here, but you don’t have to. I skip this option on import, choosing instead, 

to rename my files after my initial pass through them.  It seems that I inherently have images that I will delete for one reason or another 

(they are out of focus, of the ground, improperly exposed, etc.).  Note: If you decide to rename your files (regardless of when) and use an unre-

lated naming convention, be aware that the DNG file names will no longer correspond with the original camera manufacturer’s raw file names. 

Personally, this is not an issue as I would only return to the camera manufacturer’s original proprietary raw files as a last resort.  

If or when you choose to rename your images, I would suggest developing a file naming schema that makes sense to you and stick to 

it - consistency is key! Here are a few examples:

	 Template in Lightroom			   Examples of Renamed Files

	 Date (YYYY)_JKOST_Sequence #00001	 2007_JKOST_00001	 2007_JKOST_00002	 2007_JKOST_00003

	 CustomText_JKOST_Sequence #01		  Assignment1_JKOST_01	 Assignment1_JKOST_02	 Assignment1_JKOST_02

	 File Number Suffix_Date(YYYYMMDD)		 8365_200708210		  8366_20070810		  8367_20070810	

• Develop Setting - apply as desired.  For example, if your assignment is about composition and you want the files to be displayed as gray-

scale, then have your student apply the General - Grayscale preset.  Of course any develop settings that you apply here are nondestructive 

and can be removed or altered at any time.

• Metadata - create a template which includes information that should be applied to every image.  For example, this template might include 

the student’s copyright and contact information.  Multiple templates can be created and stored for different uses.  All of this information 

can be added to, altered or removed in Lightroom at any time.  For example, students may need to add a caption to their files which can 

be done in Library module in the Metadata panel.

• Keywords - this is the easiest way to add general keywords.  Adding a keyword for the location, name of the client, or class assignment 

number for example will enable images to be quickly found years later by searching on this controlled vocabulary. Individual, image 

specific keywords can be added to files after import.

Sorting and Organizing images (Library Module)

After importing, the next logical step is to organize your images.  Of course you don’t have to follow the steps outlined below, but I have found 

them to be a good starting place when editing down large volumes of images to my selects or “best of shoot”.   

• Identify any unwanted images.  I find that the reject flag works well for this.  As I move through the grid (or loupe view) in the Library, 

I can tap the “X” key to flag an image as rejected.  Then, by choosing Filter > Filter by Flag > Rejected Photos, I can view and confirm the 

rejects.  A quick Edit > Select All and then Photo > Delete Photos, allows me to either Remove from the Lightroom Catalog - in which 

case the file(s) will still remain on disk, or Delete from Disk- in which case the file(s) are deleted from the catalog and placed into the trash 

(Macintosh) / recycle bin (Windows).

• Batch rename images.  This is a good time to rename images with a sequence number because any unwanted images will already be 

deleted.  Note: see above for file renaming examples.

• Rate images based on a star scale (the more stars the higher the quality of the image) and be sure to clearly define what each star means. 

For example, to be rated a one star, the images must be both technically accurate and aesthetically pleasing.  For two stars, the images 

must be the best of the group and for three stars, it should be on the cover of the photography issue of Communication Arts!  Try to limit 

the maximum number of stars to one or two so that as the students improve, they are able to add additional stars to their better images. 

Note: it’s best to be conservative with your ratings - ideally giving no more than 10% of each shoot a star rating, otherwise in a year there will be 

so many rated images that the rating won’t mean anything.

 • Add additional labels to files - color label information (both color and text), can provide additional organizational levels.  For example 

images can be labeled for submission to stock agencies, as a reminder to print, or to include as part of an online portfolio.

• Refine Keywords - apply additional keywords that uniquely describe each image.  I try to add an additional 4 descriptive keywords 

(minimum) per image.  For higher rated images, I spend more time adding additional keywords.
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• Create and organize groups of images into user-defined Collections - these can be very helpful in determining which images fulfill certain 

assignments, might be used to create panoramas, could be a part of a more complicated multi-layered composite, etc. - without having 

to physically move those images on disk.

• Stack - group related images together displaying the best image at the top of the stack making navigation in grid view faster and more 

efficient.

Develop the Perfect Negative (Develop Module)

Once you have organized and prioritized your images, it’s time to make and refine any changes to exposure, color and  other develop settings. 

The goal in the Develop module is to create the perfect negative - of course that might mean very different things to different people, but 

the objective is to get the image in the state that is optimal for you.  It is advantageous to make any necessary changes here, in the Develop 

module, before you move on to any other external image editing application.  I compare the raw DNG file to a traditional “latent image on film”. 

- one that has been exposed, but not processed.  In Lightroom, you can adjust any settings you want to use to process the image (analogous 

to changing the dilution of the chemistry, temperature and time of film processing) without making any destructive edits to the original.  And 

you can change your mind and re-process the images at any time!  Talk about the ultimate in flexibility! 

So, what to do first?

• Virtual copies - if desired, choose Photo> Create Virtual Copies to create a second thumbnail which represents the original image.  This 

enables you to make adjustments to the copies while still being able to quickly access the original image and settings.  This is not a manda-

tory step, but it can be helpful if an assignment calls for two versions of the same file.  For example, a print of the before and after image 

or a web photo gallery with both a grayscale and color version.  The largest benefit of working with virtual copies is that, regardless of 

how many you create, all virtual copies reference the single original file on disk (saving space).  Lightroom simply displays the necessary 

previews of the virtual copies based on the changes made in the develop module.  And keep in mind that any and all changes can be 

removed or altered at any time without ever changing the original. 

• Crop and Straighten - before making any tonal or color adjustments, use the Crop and Straighten tools as necessary.

At any time, you can choose Edit > Undo to undo the last change.  You can also use the History panel to move back through multiple states in time and 

create a Snapshot at pivotal points in adjusting images.  In addition, you can display a before and after view of the image by clicking on the Before/

After icon in the tool bar and turning off individual panels using the on/off icon to the left of the panel name. 

The following adjustments are not necessary for every image.  Use them as desired, starting at the top (the “Basic” panel) and working down 

through the rest of the list. 

• Set the white balance using the eyedropper and make exposure, clarity and vibrance corrections in the Basic panel.

• Further fine tune the exposure with the Tone Curve and Color Balance panels.

• Apply  “special effects”  using the Grayscale and Split Tone panels.

• Use the Details panel to remove unwanted noise and add sharpening.

• Use the Lens Correction panel to remove any lens aberrations and enhance or diminish vignetting effects caused by a lens. This feature 

was designed to correct the darkening of edges when using wide angle lenses.  It’s important to note that the vignette controls effect 

the entire image, regardless of any cropping.

• Remove any imperfections using the Heal, Spot and/or remove red eye tool.

Once you’re finished making corrections to one image, you can copy and past those changes to other images, select multiple images and batch 

synchronize them or save any single or set of valuable adjustments by creating presets which are then available to use with other images.
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Further enhancements in Photoshop

For some photographers, the Develop module might represent the concluding extent of the changes that they will make to an image.  Their 

work is done, the perfect negative has been created, and from there, they will move directly to the output modules in Lightroom where they 

will create slide shows, prints or perhaps, web photo galleries. 

But not me. Digital photography has opened doors to a world where all of the time in the universe would not be enough to explore.  One in 

which there are endless possibilities -the paint is never dry, the exposure is never fixed, and the print is never final.  All of it can be done differ-

ently at any point. Here, the art form is knowing when to stop. It’s about realizing when you’ve said what you set out to say.

So, how does one move from Lightroom to Photoshop to continue editing?  Well, I find that typically, one of two scenarios arises:  I either want 

to work with “one” or “many’ images at a time.  Although that doesn’t sound like much of a difference in workflow, the number of images that 

I’m working with actually defines the approach that I take at this point.  If I have relatively few images and want to work on them one at a time, 

then I’ll choose the first option below, if I need to work with many images, I’ll choose the second option.

OPTION 1 -  When working with only a few photos, typically one at a time.

• Back in the Library module, Select Photo > Edit in Adobe Photoshop CS3. Lightroom displays the options for editing. Choose Edit a Copy 

with Lightroom Adjustments and choose the desired Copy File (or rendering) Options.  The following options render the highest quality 

and largest color space - TIFF, Pro Photo16 bit (this also will result in the largest file size).  If you prefer to work  with a smaller file size and 

color space, then choose - TIFF, Adobe RGB 8 bit (I find this to be a very good compromise when doing elaborate multi-file composite work. 

I might not have as much overhead to make selective tonal and color changes to the images, but they’re so much smaller and therefore 

faster to work with). 

• As Lightroom renders the file, it automatically saves it to disk (in the same location as the original) and imports it in to the current catalog.  

Lightroom will also open Photoshop (if it’s not already running) and open the rendered file.  This seamless integration  between Lightroom 

and Photoshop makes keeping track of edited files a breeze.

OPTION 2 -  When working with multiple files  that need to be edited. 

• In this scenario, I would choose to export the files. In the Library module select the images that need to be exported and select File > 

Export, or click the Export button in the lower left of the Develop Module.   Select an Export Location by choosing a destination folder 

and if desired rename your files.  Again, I would suggest that you develop a file naming schema that makes sense to you.  Typically I will 

keep the original file name and then add a single letter to represent whatever is unique about the image (L for Layered, F for flat, S for 

Sharpened, etc.).  As I make additional changes and need versions I will add a sequence (Image01L_01.psd, Image01L_02.psd, etc. ). 

• Next, choose a file format.  This depends on what you’re going to use the image for.  For example if I were submitting images for an 

assignment, I would export them as DNG with the same options as suggested in the import section.  If I was going to work on them in 

Photoshop I might export them as TIFF or PSD using the same recommendations for image settings as in the first option (above). Since 

I would be rendering the file out to pixels, at this point, it would be best to define the anticipated print size by entering a width, height 

and resolution.  

• Finally,  I would choose to not check Minimize Embedded Metadata, and would check Write Keywords as Lightroom Hierarchy.  Post 

Processing > After Export, I typically choose to Do Nothing, but you also have the option to Burn to Disk, or Open in Photoshop.  The pri-

mary advantage to exporting multiple files is that while Lightroom is creating the files, you can work on something else.  The only caveat 

is that after exporting the files, Lightroom does not automatically re-import them into the Library.  To do this, you will need to choose 

File > Import and make Lightroom aware of the files.  Or, if the folder containing the images already exists in Lightroom, import them by 

choosing the folder in the Folder panel and selecting Library > Synchronize folder. 

Regardless of your workflow, after selecting to Edit in Photoshop or Exporting files, further enhancements or creative manipulations can be 

made.  When choosing Edit in Photoshop, the file is automatically opened in Photoshop so it’s seamless to continue working.  If you’ve exported 

files, you can either import them back into Lightroom, or, if desired, use Bridge to browse the exported images.  Bridge presents advantages 

such as accessibility to the Automate tools (Merge to HDR, Photo Merge etc.) as well as file handoff to smart objects. 
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Turning in Final Files for Assignments

If manipulation in an external image editing application such as Photoshop is not allowed for an assignment, then the easiest method for 

collecting files from student is to have them select the files in Lightroom and choose and File > Export.  DNG has the following advantages:

• DNG eliminates the need for students to submit both camera manufacturers proprietary raw files and sidecar files. 

• DNG embeds metadata such as copyright and develop settings within the file. 

• All changes made to DNG files can be temporarily removed to view the original exposure, crop, color settings etc. 

• Exporting will automatically create separate DNG files for any virtual copies that have been made.  

When exporting, students should save the files to an appropriately named folder (see illustration on page 2).  After export, images can be 

quickly burned to DVD,  uploaded to a server etc..  If images are to be submitted after working in Photoshop, decide on a width, height and 

resolution as well as bit depth, file format and whether or not you want to collect layered or flattened files. 

Output

Depending on the class, you may require students to create slide shows, print work or post web photo galleries.  Options for all of these methods 

of output are available in the three remaining modules but are beyond the scope of this document.

 

Archiving

The entire student folder needs to be archived by each student on an ongoing basis. If possible, the master folder and all of it’s contents should 

be saved in at least two places.  For example, if the student has access to a server, they can store one copy there and another could be to CD 

or DVD.  However, portable hard drives are my preferred method of backup because of their speed and convenience. 

FAQ 

Q. If students shoot more than one card - can they put more than one folder of images in an assignment?

A. Absolutely, these are only guidelines - I have found it simpler to only have one folder per assignment.  However, there may be cases 

when they shoot more than one subject, location  or lighting scenario per assignment  and would want to separate these shoots - in which 

case it may make perfect sense to have additional subfolders under the RAW and DNG folders.

Q. If students are not able to capture in a raw format what can they do? 

A. They should still use a two folder system like we did above. In order to ensure a secondary backup of their images.  For example, if their 

camera is only capable of capturing to the JPEG format, I would suggest one folder called Original JPEG and one called Working JPEG.  The 

Working JPEGs would be imported into Lightroom.  The original folder would remain untouched, as a backup. 

Q. Is there an advantage to shooting RAW plus JPEG

A. The need to capture both raw and JPEG files is diminishing as processors and software speeds increase.  Most find that the advantages 

to working with raw files (higher quality, more overhead for making adjustments, more flexible editing etc) outweighs the need for lower 

quality JPEG files (not to mention that they take additional time to write to the card while shooting as well as take up space on the card). 

If JPEG files are needed, a simple batch export from Lightroom can quickly render them from the original, higher quality raw files.  This is 

not to say that all workflows have to include raw capture.  For example, an experienced and skilled photographer who is shooting large 

volumes of images in a known lighting and therefore predictable exposure conditions, with reliable estimate for client expectations (i.e. 

the client is not going to want to order a poster size image) may very well be better off shooting JPEG files.  If they can nail the exposure, 

capturing only JPEG files will be faster to write to the card, smaller in size and faster to download and archive.  
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Q. Why on earth did you choose to use that folder or file naming schema? It doesn’t work for me.

A. Not a problem.  You certainly don’t have to use the naming schema that I suggested.  The point to take away is that whatever you decide 

on, whatever makes sense for you - use that, and be consistent.  Decide on something that you are comfortable with and stick with it. 

Q. How can you throw away your images - it’s like destroying your negatives?

A. I’ve come to the decision that if the image is truly a mistake, then I can throw it away.  I don’t want to have to view it when I’m browsing 

images, it takes up unnecessary space on my drive and requires time to archive. 

Q. Can I merge two catalogs?

A. Absolutely!  Lets say for example that you have a small catalog on your laptop (perhaps this only contains the images from your last 

shoot). On the flight home, you make extensive sorting and organizational changes.  Now that you’re home, you want to take the images 

and catalog specific information and push the data into your comprehensive image library on your desktop.  Simply launch the larger 

catalog on your desktop, choose File > Import From Catalog.  Of course the catalog and images will need to be accessible - over a network, 

or on a portable hard drive or something!  Choose the catalog of the recent shoot and voila, your images, ratings, metadata, collections, 

virtual copies etc. are now all a part of the larger catalog.  There are also choices for image management depending on where you want 

to store the original files. 

Q. When do I save my changes in Lightroom?

A. As you work on your images in Lightroom, all of the changes are being saved automatically into the database.  The only time that you 

have to be concerned about “pushing “the information from the Lightroom database into the individual files is if you want to use another 

application such as Bridge to view and process your  images.  To push information from the Lightroom database into a file, in the Library 

module, select Metadata > Save Metadata to File.  If files have been modified outside of Lightroom, and you want to incorporate those 

changes, in the Library module, select Metadata >Read Metadata from File.


