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Automating repetitive tasks in Photoshop can increase productivity as well as save time and money. Almost any command (or set of commands) 

in Photoshop can be recorded into an action to be applied repetitively to a single file or across multiple file. The most basic action will execute 

one command such as resizing an image or displaying a dialog box. More complex actions can execute multiple commands automating more 

elaborate tasks. When used with the Batch command and/or Droplets, these actions can be applied to multiple files at once, enabling Photoshop 

to do repetitive tasks more quickly than even the best-trained Photoshop user! When repetitive tasks in a more involved workflow need to be 

carried out between applications, then AppleScript, Visual Basic, or JavaScript can be used to create scripts which work with Photoshop. In the 

case of conditional logic (a fancy way of saying “Make a decision!”) when an action needs to be applied to some files but not others, JavaScript 

files can be written to fulfill this need.  One word of caution when first trying to conquer actions - run them on duplicate files, leaving your pre-

cious originals unaltered. As you become more Action savvy, you can kick off those training wheels, and batch away!

The Actions Palette
If the Actions palette isn’t showing, select Window >  Actions. The Actions palette displays one set of actions called Default Actions.atn. Click 

the disclosure triangle next to the set of actions to reveal its contents (clicking again hides the contents). This default set of actions contains a 

variety of different actions used to display pre-made workspaces - used to determine menu visibility and colors. (The ability to customize menus 

is new to Photoshop CS2.) On the Actions palette, click to select the “What’s New in CS2 Workspace” and click the play button to play the action 

and switch workspaces. A dialog will appear warning you that it will modify menu and/or keyboard shortcuts sets. If that’s OK with you, click 

Yes to apply the workspace. When you view your menus with the new workspace loaded, every new feature appears highlighted in blue. If you 

would like to reset your workspace, select Window > Workspace > Default Workspace.

Photoshop CS2 has additional pre-made actions which ship with the program and can be loaded into the Actions palette. To use these actions, 

from the Actions palette menu, select the set from the bottom of the list (Commands, Frames, Image Effects, Production, Sample Actions, Text 

Effects, Textures  and/or Video Actions).  We’ll talk more about saving and loading actions later.

Creating Single-Command Actions
Any Action you create needs to be in a “Set”, which looks like a folder. We’re going to start by creating our own Set of actions. This allows us to 

keep them separate from the default set and helps keep them organized. On the Actions palette,  select “New Set” from the palette menu. In the 

New Set dialog box, name the set “Single Commands” (or something that will make sense to you), and click OK. On the Actions palette, the new 

set is automatically targeted and any new actions you create will be placed in that set. Note: Both actions and sets of actions can be rearranged 

at any time by simply targeting it (by clicking on it) and dragging it to a new position in the palette.

 To begin, we’ll create a simple action and assign a function key to trigger it.  This will enable a single keystroke to automatically carry out a 

menu command.  By assigning a function key, we can create keyboard shortcuts for commands that don’t have them - for example, Fit Image 

or Flatten Image.  You’re probably saying, “Hey, Photoshop CS2 HAS customizable keyboard shortcuts.” Well, there are still advantages to using 

Function keys. For example, they increase the total number of keyboard shortcuts available! Before beginning to record the action, open a 

multi-layered document (or create a new one). Then, using the Actions palette menu, select “New Action” (or simply click the “New Action” icon 

at the bottom of the palette).
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In the New Action dialog box, give the action a name. Use the Set option to define which set Photoshop puts the action in. Use the Function Key 

command to assign a Function key to trigger the action. Note: although it might look like there is a relatively small number of function keys to 

use, they can be used in conjunction with keyboard modifiers,  (Shift and Control on Windows, Shift and Command on the Macintosh) effectively 

quadrupling the number of function keys available. Choose the color coding option to help identify and/or group your actions by color when 

viewing your actions in button mode (more about this later). Finally, click Record to begin recording the action.

While recording, Photoshop will keep track of nearly all of the commands that you choose. (For a list of items that can not be recorded, see the 

end of this tip). Select Layer > Flatten Image. The image is flattened, and the command Flatten Image is listed in the Actions palette. Note: when 

you record an action, Photoshop records what happened (as opposed to the exact menu command), so don’t let this confuse you. For example, 

when adding a new layer, Photoshop lists the command as “Make layer” in the Actions palette.

To stop recording, from the Actions Palette, use the fly out menu and select “Stop Recording” (or simply click the stop recording icon at the bot-

tom of the palette). To play the action, open a layered file (or revert the one used to create the action) and, from the Actions palette, use the fly 

out menu to select Play (or simply click the play button at the bottom of the Actions palette). However, since we assigned a Function-key to the 

action, we can also use it to  play the action. This enables us to have the actions palette closed, saving screen real estate and still run them. Note: 

Photoshop CS2 adds the function and modifier key to the right of the action name which is convenient since I can never remember which F-key 

I assigned to an action!  If you prefer, you can select “Button Mode” to view your actions as “pushable” buttons and view any assigned F-keys. 

You might find that working with the actions listed in button mode enables you to select them more quickly. You can also stretch the Actions 

palette in button mode to list multiple columns of buttons along the bottom of your screen (or reposition them to a secondary monitor). There 

are, however,  a few disadvantages to working in Button Mode:  you can’t target individual steps, nor can you create new actions, for example. 

Select “Button mode” again to return to normal mode.

Now create a second action - this time for resizing an image. Instead of using the Image Size command, we’re going to select File > Automate > 

Fit Image. This is going to allow us to set up the maximum length and width of an image so that we can use the same action on both horizontal 

and vertical images. Open any file in Photoshop (or create a new one). In the Actions palette, select the set in which you’d like the action to be 

placed, and from the palette menu, select New Action. Name the action, assign an F-Key and a color (if desired), and click “Record.”

Select File > Automate > Fit Image, and enter the desired size. If, for example, you need all of your images to fit within a 6 inch area and you 

are working at 300 pixels per inch, you would enter 1800 pixels for width and height.  Click OK. On the Actions palette, note that the Fit Image 

command is recorded. If you click on the disclosure triangle next to the command, you can see that the specific parameters that you recorded 

are listed. 

To stop recording, from the Actions Palette, use the palette menu to select Stop Recording (or simply click the stop recording icon at the bottom 

of the palette). To play the action, open another file (or revert the one that is open) and, use the Actions palette menu to select Play (or simply 

click the play button at the bottom of the Actions palette). Or, use the assigned Function key. The image is resized to the parameters you set 

using  the first document.

If you want Photoshop to display the command’s dialog box instead of automatically applying the same recorded values to every image, you 

can click in the empty well to the left of the command (on the Actions palette) to display the dialog box.  Now, playing the action results in the 

Fit Image dialog box being displayed so that the values can be customized as needed on a document-by-document basis.

Creating Multi-Command Actions
To create a more complex action that contains multiple steps is as easy as recording multiple commands. For example, to create an action that, 

converts the image into a sepia tone, runs a filter, adds a vignette,  adds some extra canvas size around the image, adds a dropshadow, and saves 

the image as a different format, select New Action, click record and select the following commands:

• Image > Flatten (if you’re working with multi layered images)

• Image > Mode > RGB (if you’re working with Grayscale images)
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• Image > Adjustments > Hue/Saturation (check Colorize and use the hue and saturation sliders to choose the desired color)

• Click the default swatches icon

• Filter > Distort > Diffuse Glow

• Filter > Distort > Lens Correction (add the desired vignette)

• Layer > New > Layer from Background (so that you can add transparency around  the photo)

• Image > Canvas Size (increase the size of the canvas as desired)

Layer > Layer Style > Drop Shadow

• File > Save As and select JPEG with a setting of 10

• Select Stop Recording.

Play the action on a different file. If you toggle on the dialog option next to the Hue/Saturation command, you can specify a different hue for 

each image.

Making Changes to Actions
Individual commands, their attributes, or entire actions and sets can be modified, expanded, deleted, duplicated, and reordered so if you make 

a mistake while recording, don’t worry, you can always go back and edit the action later. 

If you want to remove a step from a command, you can select Delete from the Action palette menu, drag the command to the trash icon on 

the bottom of the palette, or temporarily exclude a step by clicking the check mark to the left of the command. If  you want to add a step, select 

start recording from the Action palette menu, or if you already have that command recorded in another action you can Option (Mac) / Alt (Win) 

drag the command from one action to another. (Not using Option (Mac) / Alt (Win) will simply move the command from one action to another).  

If you want to record the same command to be performed multiple times, you can select it repeatedly while recording, or select Duplicate or 

Record Again from the Actions palette menu.

Other Commands
Some items in Photoshop don’t appear to be recordable.  For example, if you’re recording an action and select View > Actual Pixels the image 

changes on screen (provided you’re not already viewing the image at 100%) but no command is added to the Action. To add this command, 

you must select “Insert Menu Item” from the Action palette menu.  With the Insert Menu Item dialog box showing, select View > Actual Pixels. 

You’ll see the path for the command listed at the top of the dialog box. Click OK to add the command to the Action. A key difference between 

recording a step and using the Insert Menu Item is that the Insert menu doesn’t allow toggling on and off the dialog box for that command. 

You can see that the dialog box option is greyed out, and that it cannot be toggled. Therefore if you want to change the values on an image-

by-image basis by showing the command’s dialog box, its better to record the command than insert it. 

Use the Insert Stop command to insert a message, explanation, or reminder. This is especially useful if you’re creating and sharing actions with 

others. Use the Actions palette menu to select “Insert Stop.” In the Record Stop dialog box, add a message and choose whether or not to allow 

the action to continue. If the action requires that something be done, (make a selection for example) then do not allow it to continue. If the ac-

tion is a reminder (such as “Make sure the image is RGB before playing the action.”), then check “Allow Continue.” If the action is stopped, click 

the play button at the bottom of the Actions palette to resume playback.

Action and Playback Options
In order to change the name of an action, you can either double click the action in the Actions palette, or select Action Options from the Action 

Palette menu.  You can also change the F-key assigned to the action and color coding in this dialog box. If you want to place the action in to 

another set, drag the name of the action to the new Set. To make a copy of the action into another set, hold down the Option (Mac) / Alt (Win) 

key while dragging the action. 

To control the playback of actions, select Playback options from the Actions palette menu.  Typically I leave mine to Accelerated to play the action 
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as fast as possible. However, if you’re trying to troubleshoot your action you might want to select some of the other options. Step by step will 

slow down the action so that the screen redraws the result of each step, but that’s typically not slow enough for me. When I’m troubleshooting, I 

typically enter a number of seconds to pause for. This helps me to see what is happening at each step and what I’ve done incorrectly! The option 

to Pause for Audio Annotation pauses the action long enough to play any  audio annotations recorded in the action.

Saving and Sharing Actions
When you’re finished creating actions, I would suggest that you save them. Photoshop only saves the contents of the actions palette when you 

quit the application. It only took me one experience to learn this. I had spent all evening creating a very intricate action with dozens of steps. I 

finally went to bed without saving the action or quitting Photoshop. Unfortunately, the power decided to go out that night crashing Photoshop 

without saving the action. Poof, all that hard work was gone. Before trying to save an action, you have to know that individual actions can’t be 

saved, you must save a Set (although a Set can include only a single action). In fact, only when you have a set targeted in the Actions palette will 

you be able to select Save Actions from the palette menu.  If you’re saving actions that are going to be used cross-platform, be sure to include 

the .atn extension.

 If you’re sharing actions with friends and colleagues, you can use the Actions palette menu to select Load Actions. Navigate to the Actions file 

(.atn) and select Load Actions. In Photoshop CS2 you can also double click on an action file in the Bridge to automatically load it. The set will now 

appear in the Actions palette. If you store sets of action in  the  Photoshop folder  > Presets > Photoshop Actions folder, then they will automatically 

appear at the bottom of the Actions palette menu so that you can simply select them from the list to load them.  When working with multiple 

sets of actions, you can also choose to Clear All Actions, Reset Actions (to their default) or Replace actions from the Actions palette menu.

Batch Processing
With the introduction of Photoshop CS2, you now have additional choices as to how you decide to batch process actions. You can either select 

the images that you want to batch from the Bridge and choose Tools > Photoshop > Batch, or in Photoshop you can select File > Automate 

> Batch.  The advantage of using the Bridge is the additional control you have over selecting you images. For example, you can use the Find 

command to find specific images and have the Bridge display them in a search results folder. Then you can reorder them into your own custom 

sort order if desired. You can then select all (or even further refine your selection) and batch process those images. This has saved me a great 

deal of time just by allowing me to batch process files that are in many different folders without having to make copies or rearrange my folder 

structure. Another advantage is that if you choose to batch process from the Bridge, you can work in Photoshop while the Bridge is processing 

files and vice versa. 

Whichever way that you select to proceed, the batch dialog box appear be almost identical. There is one minor difference. When you select it 

from the Bridge, it will run the batch on the selected folders. If you select it from Photoshop, it will ask you which images you want to batch (see 

the source options below). 

In the Play area, select the Set and the Action desired. 

In the Source area, select the source files that you want to run the action on:

• Select Folder to select a folder of images to process. If you select this option, use the Choose button to navigate to the desired folder. 

• Select Import to processes images from a digital camera, scanner, or a PDF document.

• Select Opened Files to use currently opened files.

• Select Bridge to process selected files in Adobe Bridge. If no files are selected, al of the files in the current Bridge folder are processed.

•Select “Override Action Open Commands” if you want any Open commands (recorded in the action) to be ignored.  If you include the 

open command as part of an action, Photoshop will open the SAME file each time the action is performed. Unless you want the same file 

modified over and over, deselect this option. Activating this option is handy if you need to open a specific file, such as a backdrop, which 

needs to be used with every image. 

• Select “Include All Subfolders” to process files in folders within the master folder you’re selecting. 

• Select “Suppress File Open Options Dialogs” if you want Photoshop to bypass  open dialog boxes such as the Camera Raw dialog box, 

opening Raw files with their default settings or with any setting applied to them.
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• Select “Suppress Color Profile Warnings” to turn off display of color policy messages. 

Choose a destination for the processed files from the Destination menu.

• “None” leaves files open without saving changes (unless the action includes a Save command).  This gives you an opportunity to see the 

results of the action before saving the file.

• “Save and Close” saves the files in their current location, OVERWRITING the original files.

• “Folder” saves the processed files to a folder in another location. If you select Folder, click Choose to specify the destination folder. 

Select  “Override Action Save In Commands” to ignore any save commands recorded in the action. Deselect the option if the action contains 

Save As commands for specific files that are required by the action. For example, if you have a JPEG file that is the front cover of your newsletter, 

you could choose to resize, color balance, and sharpen the image, and then save it as “frontcover.psd” for importing into InDesign. This allows 

you to have an intermediary file as the result and leave the original image intact.

If you chose “Folder” as the destination, specify a file-naming convention or add your own in the text entry fields. In Photoshop CS2, you can 

begin a sequentially numbered list at any number desired by entering that number in the “Starting Serial#” box. Check the options for file com-

patibility (for Windows, Mac OS and Unix) when moving files cross-platform or utilizing on the web. 

Finally, select an option for error processing from the Errors pop-up menu: “Stop for Errors” will suspend the process until you confirm the error 

message. “Log Errors to File” will record each error in a file without stopping the process (you must check this and save the file before running 

the action). If errors are logged to a file, a message will appear after processing to notify you that errors had occurred. 

Creating Droplets
You can think of Droplets as self running applications that perform actions that are associated with it on files dragged onto the droplet. To 

create a Droplet select File > Automate > Create Droplet. Click the Choose button to select where to save the droplet. For an explanation of the 

other option in the Create Droplet dialog box, refer to the section on Batch Processing above. To use a Droplet, simply drag one or more files 

(or a folder of files) onto the Droplet. Droplets continue to reference the needed Actions inside Photoshop so don’t discard your Actions after 

creating droplets for them! However, you can make changes to the Action and the Droplet will still work and will incorporate any changes made 

to the Action. Note: Running a Droplet will automatically launch Photoshop if it’s not already running.

10 useful tips when creating actions and droplets:
1. To play a single step double click on it in the Actions Palette.

2. You can save  the steps in an Actions as a text file by pressing Control-Alt (Windows) or Command-Option (Mac) while selecting Save 

Actions from the Actions palette menu. This is handy for reviewing or printing the contents of an Action. However, you can’t reload the 

text file back into Photoshop.  Note that ALL of the Actions in all sets are printed out, so you may want to limit the number of actions you 

have loaded to eliminate a lot of deleting of unnecessary information. 

3. If you constantly change the default setting for certain dialog boxes (like the default setting for the drop shadow in the layer styles dialog 

box), use actions to modify dialog boxes to open with the defaults that you like.

4. The Batch command itself can be recorded as part of an action to perform multiple batches in sequence. To batch process multiple folders 

without reorganizing them on the hard drive, create aliases within a folder to the other folders you want to process, and select the Include 

All Subfolders option (or use a droplet).

5. When moving a droplet created in Windows to Mac OS, drag the droplet onto the Photoshop icon. Photoshop will launch and update the 

droplet for use in Mac OS. On the Macintosh, add the extension .atn for actions and .exe for droplets for cross platform compatibility

6. Record an action within another by playing the action while recording.

7. Save out important actions to a secondary folder in case you reinstall Photoshop.

8. For better batch performance, reduce the number of saved history states and deselect the Automatically Create First Snapshot option 

in the History palette.

9. To create an action that will work on all files regardless of size, it is necessary to record some commands with rulers set to percentage.
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10. There are two “conditional “ commands in Photoshop: Use File > Automate > Fit Image to resize images to fit within a specific height 

OR width (using pixel dimensions) or, to selectively change the color modes of images (depending on the mode of the image), select File 

> Automate > Conditional Mode Change.

Managing Layers when Creating Actions
When selecting a layer in an action, the action records the name of the layer. If the name of the layers change from one file to another, it becomes 

necessary to use the keyboard shortcuts to navigate the Layers palette. Here is a list of keyboard shortcuts that you might find handy when 

recording changes made to specific layers. In the Layers palette to: 

Choose the layer above   Option (Mac)/Alt (Win) + [ 

Choose the layer below   Option (Mac)/Alt (Win) + ]

Choose the top layer   Option (Mac)/Alt (Win) + Shift + ]

Choose the bottom layer  Option (Mac)/Alt (Win) + Shift + [

You can also arrange layers by targeting the layer and using the following shortcuts

To move up one layer    Cmd(Mac)/Ctrl (Win) +[

To move down one layer  Cmd(Mac)/Ctrl (Win +]

To move to the top   Cmd(Mac)/Ctrl (Win) +Shift +]

To move to the bottom   Cmd(Mac)/Ctrl (Win) +Shift +[

Three pitfalls to beware of:
1. Size-specific features such as type size, feather, and unsharp mask generally won’t give the effect intended if you’re working with files 

of a different size than that used to record the action. For example, a 3-pixel Gaussian blur won’t create the same effect on a 72-ppi file as 

on a 144-ppi file. 

2. Some of the painting tools, tool options, View options, preferences and window commands cannot be recorded. However, many com-

mands that cannot be recorded can be inserted into an action using the Insert Menu Item command.

3. There is no way to access the file name while running an action, but you can if you use Java Script. There is a script that on www.adobe-

evangelists.com in the action area that you are free to download (addfilename). Just place the script in your Photoshop CS2/Presets/Scripts 

folder.

Scripting in Photoshop:
Photoshop CS2 automatically installs support for scripting so you can write and run scripts. Scripts can be written in AppleScript or JavaScript 

on the Macintosh. On windows you can use JavaScript, Visual Basic or any other OLE Automation. Scripts can range from simple manipulation 

of a single selected object to complex control of multiple documents. They can run commands and even execute actions. 

Photoshop CS2 installs scripts (found under File > Scripts) that enable you to export layers to individual documents. The first script (Export Lay-

ers to Files) allows for exporting multiple layers into individual files making integration with non-Adobe applications much easier. The second 

(Image Processor) allows you to save out files as multiple, different file types (PSD, TIF and JPEG) all within a simple dialog. You can even choose 

to run an action as part of the save. In addition, you can export Layer Comps to Files, Layer Comps to PDF, and Layer Comps to Web Photo Gal-

lery. These three scripts are great when you want to try out several versions of a design using Layer Comps, and then share them with clients. 

It’s particularly cool that you can do several designs in one document, and then make a Web Photo Gallery that features client review tool so 

that you can conduct a Web-based review very quickly. 

The Scripts Event Manager (File > Scripts > Scripts Events Manager), new to Photoshop CS2, allows you to take an event such as opening, saving, 

or exporting a file in Photoshop, and trigger a JavaScript or a Photoshop action based on that event. Photoshop provides several default events, 

or you can have any scriptable Photoshop event trigger the script or action. Photoshop has several sample scripts you can choose. Choose 

Browse and then navigate to the script. For actions, choose the action set from the first pop-up menu and an action from that set in the second 
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menu. The action must be loaded in the Actions palette to appear in these menus. Click Add. The event and its associated script or action are 

listed in the dialog box. To disable and remove individual events, select the event in the list and click Remove. To disable all events, but keep 

them in the list, deselect Enable Events To Run Scripts/Actions.

In addition, you can add scripts to run from Adobe Bridge. They will appear under Tools > Photoshop. For information about creating your own 

scripts, see Bridge JavaScript Scripting Reference.

In the Photoshop CS2 application folder is a guide to scripting with information on JavaScript, AppleScript, VisualBasic as well as sample scripts 

if you’re interested in making your own. In addition the Technical information folder on the Resources and Extras CD included with your Adobe 

product includes several useful documents in PDF, fully searchable and optimized for printing. These documents provide conceptual and refer-

ence material on various in-depth topics, such as scripting. For complete developer documentation and resources, visit the Developers area of 

the Adobe web site at http://partners.adobe.com/public/developer/main.html. For additional instructional content, visit Adobe Studio.

Data-driven Graphics in Photoshop CS2
Data-driven graphics make it possible to produce multiple versions of an image quickly and accurately. Let’s say, for example, that you need to 

produce 500 different Web banners or 200 different business cards based on the same template. In the past, you had to manually populate the 

template with data (images, text, and so on). With data-driven graphics, you can use a script referencing a database to generate the Web banners 

for you. In Photoshop CS2 (as well as ImageReady CS2) you can automate this process with the Variables feature. Basically, you design a template 

in Photoshop or ImageReady, putting all of the elements that will change (the variable elements) on separate layers,  and then select layers in the 

template and assign them as variables. You can then quickly generate an unlimited number of unique variations based on the original template 

by using scripts to replace the variable elements. Photoshop and ImageReady allow you to assign three different types of variables:

• Visibility variables let you show or hide the content of a layer.

• Pixel Replacement variables let you replace the pixels in the layer with pixels from another image file.

• Text Replacement variables let you replace a string of text in a type layer.

To define a variable in Photoshop or ImageReady, target the layer and select Image > Variables  Define. In the Variables dialog box, choose the 

desired variable type and enter names for the variables. Note: Variable names must begin with a letter, underscore, or colon and cannot contain 

spaces or special characters (except for periods, hyphens, underscores, and colons). For Pixel Replacement variables, click Pixel Replacement 

Options, and choose a method for scaling the replacement image. To define variables for an additional layer, choose a layer from the Layer 

pop-up menu and repeat the steps above.

After defining variables, you can manually input the data for each image, or import the data from a file into a data set. A data set is a collection 

of variables and associated data. You can switch between data sets to upload different data into your template. You can create a new set or 

edit the default data set. To create a new set, select Image Variables > Data Set. Then, import the data that you need from an Excel spreadsheet, 

Filemaker database or any other source data that’s been exported as a comma- or tab-delimited file.. Note: You must define at least one variable 

before you can edit the default data set. To change a data set, simply select the data set you want to modify (from the drop down menu in the 

Variables dialog box), edit the data and click the Save Data Set button. To delete a data set, select the data set you want to delete, and click the 

Trash button.

Once you have imported data, you can preview the different graphics generated by the data sets by clicking the preview button and select-

ing the data set from the list. You can also use the next and previous triangles to navigate through the graphics. The data being displayed will 

change in the document window. 

To export Data Driven Graphics, select File > Export > Data Sets as Files. You can output individual images as PSD files from Photoshop or as 

optimized images or SWF (Flash) files from ImageReady allowing you to create an unlimited series of graphics for any use, dynamically gener-

ated, with no programming knowledge required. 


