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Menu and Workspace Customization

Photoshop CS2 continues to be more and more customizeable for your individual workflow. You can use the new Menu panel to highlight 

menu and palette items that are important to your workflow as well as hide unused menu items. By default, all of the menu and palette items 

are displayed in Photoshop CS2. In addition, a variety of presets are available for tasks such as Color and Tonal Correction or Printing and 

Proofing. There is even a preset menu that displays “What’s new in CS2”. Choose a preset under Window > Workspace and select one from the 

list to display the associated workspace. 

To go beyond the default presets and customize menus and palette items for your specific workflow, select Edit > Menus or Window > Work-

space > Keyboard Shortcuts and Menus. Click on the Menu tab and use the “Menu For” option to select Application Menus or Palette Menus. 

Use the disclosure triangle next to the menu or palette item to display the customizable items. Click the Visibility button (the eye icon) to hide 

or show the item. Click the word none under the Color column to color a menu item (you can select from 6 different colors or gray). 

To save settings and create a new set based on the current set of menus, click the save icon. To delete a saved setting, click the trash icon. 

Notice that even if you accidently click on the save icon after making changes to the Photoshop defaults, you can not save over them; they’re 

automatically renamed “Photoshop Defaults (modified)”. If you want to save your settings and share them with peers, simply place a copy of 

the .mnu file in the Adobe Photoshop CS2 > Presets > Menu Settings folder. The settings will automatically load the next time you launch 

Photoshop. If you ever have the need to rename a .mnu file, go to the Adobe Photoshop CS2 > Presets > Menu Setting and rename it on the 

hard drive. Once you have saved menu settings, they appear under the “Set” drop down menu in the Keyboard Shortcuts and Menus panel. 

If you have chosen to hide Menu or Palette items, a command to “Show All Items” will be added to the bottom of the Menu or Palette. To tem-

porarily see hidden menu items, click on “Show All Menu Items” or Command (Mac)/Control (Win) click on the menu. 

You can edit your menus and then save them as part of a workspace so that they work in combination with palette locations and keyboard 

shortcuts. Select Window > Save Workspace and check to capture Menus, Palette Locations, and Keyboard Shortcuts (if desired). The workspace 

appears at the bottom of the Window > Workspace menu.

Photoshop CS2 takes this one step further by allowing you to assign keyboard shortcuts to your workspaces. Select Edit > Keyboard Shortcuts 

and choose Shortcuts For: Application Menus. Click the disclosure triangle next to Window and scroll down to reveal Workspace. Click in the 

Shortcut area to the right of your workspace name and enter your custom keyboard shortcut. Now, with a single keyboard shortcut, you can 

control your palette locations, menu and palette items visibility and color and keyboard shortcuts.

Multi-layer select

• Photoshop CS2 now allows you to intuitively select multiple layers giving the application a more “object oriented” feel to it. You can select 

multiple layers from either the image area, or from the Layers palette. Once multiple layers are selected, they can be moved, transformed, 

aligned, grouped, warped etc. 

• To select multiple layers in the image (document) area, first select the Move tool. In the Options bar, check “Auto Select Layer”. Clicking on 
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pixel data within the layer desired will select it. To select more than one layer, shift-click on the layers in the image area. Shift clicking on an 

already selected object unselects it. You can also click and drag over objects on layers to select them in the image area. This method works 

well if you have multiple objects (layers) and a Background. Otherwise, because you have the Auto Select feature turned on, it will select 

the first layer that you click on and begin to move it instead of selecting additional objects (layers). Because a Background is locked by 

default, it is impossible to select and therefore skipped by the Auto Select Feature. If you have layers that you do not want to auto select, 

lock them. Note: If you prefer to keep the Auto Select Layer unchecked (off ) with the Move tool selected, you can use the keyboard shortcut 

Command (Mac)/Control (Win) to temporarily turn on the auto select functionality. 

• To select multiple layers from the Layers palette, Command (Mac)/Control (Win) click on multiple layers (click to the right of the layer or 

mask thumbnail, in the name area). Shift click to select a range of contiguous layers in the Layers palette. 

• To copy files from one document to another, you can either drag and drop multiple selected layers, or copy them (Edit > Copy) using 

Photoshop’s new multiple layer clipboard format. 

• When selecting multiple objects with the Move tool, you have the option to check “Show Transform Controls” (in the Options bar) to have 

Photoshop display a bounding box around selected objects. Not only does this help to show which layers are selected but can also be 

used to quickly transform an object with out having to use the Free Transform command. 

Layer Groups

• Photoshop CS2 has renamed Layer “Sets” to “Groups” though their functionality has not changed. 

• To add a new Group, select Layer >New > Group, or click on the New Group icon (the folder) at the bottom of the Layers palette. The group will 

be added above the topmost currently selected layer. If no layers are selected, Photoshop adds the group to the top of the layer stack.

•To create a new group while simultaneously placing selected layers into the group, select Layer > New Group from Layers or drag the se-

lected layers in the Layers palette to the New Group icon (the folder) at the bottom of the Layers palette. The group will be added above the 

topmost currently selected layer. If no layers are selected, Photoshop adds the group to the top of the layer stack. Command (Mac)/Control 

(Win) + G places selected layers together in a group. Note: this changes the default shortcut for Create Clipping Mask to Command+Opt 

(Mac)/Control+Alt (Win) + G.

• To ungroup layers, select Layer > Ungroup Layers”.

• To delete a Group, select Layer > Delete > Group or, on the Layers palette, with the Group selected, click the trash can icon. Either method 

displays a dialog with the option to delete the “Group and Contents”, “Group Only”, or “Cancel”. To delete the Group and all of it’s contents 

while bypassing the dialog (on the Layers palette), drag the Group to the trash. 

• To automatically select Groups when selecting multiple layers, with the Move tool selected, check the Auto Select Groups in the Options 

bar. Note: the Auto Select Layer option must be checked in order to check Auto Select Groups. 

Linking Layers

• With the addition of the multi-layer select option, the need for linking layers has been significantly decreased - you can now transform, 

move, align, distribute, group etc. multiple layers by simply selecting them. As a result, on the Layers palette you’ll notice that there is no 

longer an empty well between the eye icon (representing layer visibility) and the layer thumbnail (representing the content contained on 

the layer) that was once used for linking. 

• To link layers, simply select the multiple layers and select Layer > Link Layer or click the Link icon at the bottom of the Layers palette. A 

new link icon appears to the right of each of the linked layer’s names.

• If you ever forget which layers are linked together or can’t see them because they are in different Groups or because the Layers palette 

is too short to display them, you can quickly select linked layers by targeting one of the linked layers in the Layers palette and choosing 

Select > Linked Layers or use the Layers palette flyout to choose Select Linked Layers.

The rules for linking layers are as follows:

• If the selection contains no linked layers (and more than one layer is selected), a new link set is created.

• If the selection contains only linked layers, regardless of whether they’re all in the same link sets, clicking the link button unlinks every-
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thing selected. 

• If the selection contains at least one layer from a single link set (and no other sets) plus any number of unlinked layers, the link set is 

extended to include the unlinked in the selection.

• If the selection contains linked layers from two or more link sets plus at least one unselected layer, everything in the selection gets put 

into a “new” linked set.

• Layers can only belong to one link set at a time.

• Command (Mac)/Control (Win) clicking on the Link icon, unlinks all layers regardless of which link set each layer belongs to. If none of the 

layers in the selection are linked, nothing changes.

• To unlink layers, select “Layer > Unlink Layers”, or select “Unlink Layers” from the Layers palette fly out. You can also use the context-sensi-

tive menus in the Layers palette to unlink layers.

Other Layer Enhancements

Because of the removal of the “well” on the Layers palette (reserved for the display of either the paint brush, mask, or link icon), a new more 

obvious indicator for layer/layer mask, vector mask selection was needed. In order to make it more apparent as to what on the layer was active 

the “framed corners selected layer icons” were created. Now, depending on what you have targeted, you will see a “double-wide” stroke around 

the corners of the layer/layer mask, and or vector mask. 

• To target a layer, in the Layers palette, click on the layer thumbnail. The framed corners appear around the layer icon

• To target a layer mask, in the Layers palette, click on the layer mask thumbnail. You can have either the layer or the layer mask thumbnail 

targeted at one time. Never both - because they are both pixel based features and Photoshop need to know which one you want to ma-

nipulate. 

• To target a vector mask, in the Layers palette, click on the vector mask thumbnail. Both the vector mask and either the layer or layer mask can 

be targeted at the same time. If you select a painting tool, Photoshop will automatically edit the layer, if you select a vector tool, Photoshop 

will automatically edit the mask. Clicking on the vector’s mask icon will hide the path in the image area and enable you to then use a vector 

drawing tool and create a new path or shape layer (as oppose to adding, subtracting or intersecting the path already in the vector layer).

• Another fundamental change is that there is now a “no layer selected” state. Hence, it is possible now to have no layers selected. This can 

be helpful if you want to quickly deselect multiple layers. To select no layers, choose Select > Deselect Layers, or click in an empty area 

in the Layers palette. With no layers selected, it can be a bit confusing because your tools won’t work and it may take you a moment to 

determine why.

• You can quickly select all layers, by choosing Select > All Layers.

• To select similar layers choose Select > Similar Layers. Similarity is based on layer type (for example, if you have a shape layer selected, it 

will select all shape layers, if you have a pixel layer, it will select all pixels layers, type, adjustment layers etc. 

There are new menu commands for some features that were previously only available via keyboard shortcut or if chosen from the Layers 

palette including:

• Layer > Delete > Hidden Layers (deletes layers with visibility turned off (the eye icon on the Layers palette).

• Layer > Layer Mask > Delete, Apply, Link/Unlink, Enable/Disable

• Layer > Vector Mask > Delete, Apply, Link/Unlink, Enable/Disable

• Layer > Hide Layers (hides selected layers).

Additional functionality was added to the behavior of the layers palette which should help to make your life easier including:

• Option (Mac)/Alt (Win) -drag to duplicate a layer in the Layers palette. Select the layer(s) and drag until yo see a heavy black line between 

the layers and release. 

• Select Layer > New > Layer Via Copy to duplicate multiple layers and Groups.

• Move a layer mask from one layer to another by clicking and dragging the mask thumbnail in the Layers palette. Option (Mac)/Alt (Win) 

-drag creates a copy of the mask. Option (Mac)/Alt (Win) + Shift creates copy while simultaneously inverting the mask.

• When you lock a layer in the Layers palette, the Lock icon now appears to the right of the layer name.
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• The Layer Effects icon appears collapsed (by default) meaning that you can not see the individual effects applied. To reveal the individual 

effects, click the disclosure triangle to the right of the “f” icon in the Layers palette (click again to collapse). To move an effect to another 

layer, in the Layers palette, drag the “f” icon. To copy a layer effect to another layer, Option (Mac)/Alt (Win) -drag the “f” icon or, click the 

disclosure icon to reveal the effects and drag a single effect (by clicking on the name of the effect) or the entire effect (by dragging the 

word “Effects”).

• Option (Mac)/Alt (Win) + Merge Visible automatically creates a new layer to merge onto.

• To load a layer’s transparency as a selection, Command (Mac)/Control (Win) click the layer thumbnail (instead of anywhere on the layer).

• Change preview settings for Layer thumbnails by selecting Palette Options from the layers palette flyout. Choose Change Thumbnail 

Contents to either “Layer Bounds” or to “Entire Image”.

• Also from the Layers palette fly out menu, choose Palette Options to select whether or not to add a mask to adjustment layers by de-

fault.

Smart Guides

Smart Guides can aid when trying to create, align and edit objects with respect to other objects. 

• To “turn on” Smart Guides, select View > Show > Smart Guides. Smart Guides appear when moving layers or when drawing shapes or slices. 

They will not appear when using the painting tools.

• There are a maximum of 6 Smart Guides (left and right, top and bottom, horizontal and vertical from center). They will temporarily appear 

in the image while the object is being created or when an object is selected and dragged. They will extend to the edge of center of the 

farthest object that aligns them.

Smart Objects

Smart Objects make Photoshop dramatically more flexible by adding nondestructive transformations. These transformations include but are 

not limited to scaling, rotating, perspective, distort, skew, layer styles, and mesh distortions. Non destructive manipulations also include color 

conversions, image size, image rotation, etc. Smart Objects can be created from raster or vector layers from within Photoshop or can reference 

placed artwork such as a placed RAW file, EPS, AI, and/or PDF documents. 

• To create a Smart Object, select one or more layers and/or groups and select Layer > Smart Objects > Group into New Smart Object. A 

Smart Object replaces the layers/groups in the layer stack with a single reference to the Smart Object; essentially a PSD embedded within 

the main PSD. 

• Scale the Smart Object up, down, rotate, distort, etc. as many time as you’d like with out any degradation of image quality because the 

Smart Object is always referencing the original layer(s). Hence, you are referring to the original data each time the object is transformed. 

• You can also create Smart Objects by selecting File > Place. The placed document is automatically converted into a Smart Object which 

can be reedited by the originating application at any time. For example, you may need to work with complex illustrations or logos that are 

impossible to copy and paste from Adobe Illustrator into Photoshop (they contain artwork that would otherwise need to be rasterized by 

Photoshop to keep the appearance) while maintaining as vectors. Instead of rasterizing these items, choose to place them as Smart Objects. 

Not only can you transform and warp them, you can edit them back in Illustrator or whatever the creating application was if necessary.

Here are three examples of the power of Smart objects.

• You can create a Smart Object out of multiple raster layers in Photoshop, perform non-distructive transformations, apply masks etc. If you 

need to edit the individual layers (perhaps you need to make some pixel-based edits like use the Healing Brush or color correct an individual 

layer that’s part of the Smart Object), you can select Layer > Smart Objects > Edit Contents (or double-click on the icon representing the 

Smart Object on the Layers palette). You can then edit the original, independent layers and masks contained within the Smart Object in the 

editing window (which looks and works like a regular document window displaying layer content in the Layers palette, etc.). When changes 

are saved, the Smart Object is automatically updated with the re-rasterized version - maintaining any transformations and warps. 

• If you select File > Place and select an Illustrator document, the Illustrator document automatically becomes a Smart Object. If you need 

to make changes, select Layer > Smart Objects > Edit Contents (or double click on the Smart Object’s thumbnail icon in the Layers Palette). 
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This will trigger Photoshop to launch Illustrator and open a working copy of the artwork. When saved from the creating application, Pho-

toshop will replace the Smart Object with the edited content and update the appearance. You can also copy and paste from Illustrator. By 

default, the artwork is pasted as a Smart Object (however, you can select from pasting as a smart object, pixels, path or shape layer). Note: if 

you are working in any version of Illustrator prior to CS2, you will need to change the File Handling and Clipboard preference in Illustrator 

to “Copy as: PDF and AICB”, (which is now the default in Illustrator CS2). 

• If you select File > Place and select a raw file, Photoshop will embed the raw data together with the converted pixels as a Smart Object. If 

you edit the contents of the raw Smart Object, Photoshop will bring up Camera Raw, allow you to change the settings, and when you click 

“Done”, Photoshop will replace the Smart Object with the edited content and update the appearance.

Additional features

• Multiple instances of the same Smart Object can be created by selecting Layer > New > Layer Via Copy or by dragging the Smart Object 

to the New Layer icon at the bottom of the Layers palette. Editing the contents of any of the instances of the Smart Object will update all 

placed instances of that Smart Object. 

• To create an “unlinked” duplicate of a Smart object, select Layer > Smart Objects >New Smart Object via Copy. This copy will reference it’s 

own embedded file. If you edit the contents of the Smart Object only that instance will be updated. 

• Select Layer > Smart Objects > Export Contents to export a Smart Object as an independent file, saving the original information in the 

creating applications format, or if there is a mixture of formats, as a .psb file. Think of .psb is the new .psd - it can do everything .psd can do, 

but it’s written to do away with limitations that weren’t a factor when psd was designed (principally the 2GB file size limit). Psb files can be 

opened in Photoshop CS or Photoshop CS2 and can be converted to other formats as necessary.

• You can replace the contents of a Smart Object (Layer > Smart Objects > Replace Contents). This replaces the current file, keeping any 

transformations applied - including warps! This is a great way to quickly experiment with different images because Photoshop CS2 will 

automatically transform them (although it may distort them if their aspect ration differs). 

• You can nest Smart Objects (i.e. one Smart Object inside another) but the limits on how many are unknown.

What are the penalties of Smart Objects.

• Using a Smart Object generally means that your document needs to store more data, though if you create one Smart Object from multiple 

layers, and then make multiple instances of it, you’re probably saving space (relative to duplicating those layers directly). 

• Using a Smart Object also means that you can’t make pixel level edits (paint, erase, filter etc.) directly on the Smart Object layer (although 

you can certainly edit it’s contents by selecting Edit > Contents). 

• There might be times when you need the individual items in a Smart Object to blend with other layers in a file and a Smart Objects isolates 

the blending of its contents because it behaves as one item.

• A rasterized copy of any Smart Objects (including vector artwork from applications such as Adobe Illustrator) are embedded in .psd and 

.psb files for backward compatibility (which could also add to file size).

Vanishing Point 

If you have ever wanted to maintain the perspective of an image when you clone, brush, paint, transform, etc., then Filter >Vanishing Point is 

the feature for you! There are a variety of tools located in the upper left of the dialog which allow you to create editing planes and manipulate 

them including:

• The Arrow Tool - for selecting, editing, and resizing editing planes.

• The Create Plane Tool -  for determining the perspective of the image or of an object. Click to place anchor points at the four corners of a 

perspective plane in the image. The resulting grid is referred to as the editing plane. You can use the arrow tool to select any of the corner 

points and drag to adjust the grid at any time. Creating an accurate editing plane is the most important step as all of your changes will be 

based upon it. While you’re creating the editing plane, try holding down the “X” key. As long as you have the key depressed, it will zoom in 

2x on your image, release the key to zoom back out. Notice the color of the grid while you’re drawing: The idea behind the color coding of 

the planes is to provide clues that you’re making something that might represent reality.
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 A blue grid indicates everything is valid. This does not guarantee that the grid lines up with the image, (this is the your job), but it does 

mean that it is a “legal” plane and should result in high-quality transformations.

 A yellow grid indicates that the plane does not agree with the center of projection for the image. If opposite sides of a plane are nearly 

parallel for a given image then a slight mistake in positioning in either direction can result in reversing the direction of the perspective 

(to one that is incorrect based on the image). Editing is still possible in this mode, but tearing off planes from this plane will produce 

unpredictable results.

 A red plane means that it was not possible to calculate the aspect ratio of the plane. It is not possible to tear off a plane from this “invalid” 

plane. Some editing within the plane is still supported but transformations are not.

• After dragging out an editing plane, Command (Mac)/Control (Win) -drag on a middle anchor point drags out additional grids in “dynamic 

perspective” .

• The Marquee tool makes selections inside of an editing plane and allows you to change the information within those selections. Note that 

once a tool (Marquee, Stamp or Brush) is selected, the grid lines within the editing plane are hidden so that you can see what you’re doing. 

Click and drag in an editing plane to create a selection - when you make a selection in an editing plane, the selection obeys the perspec-

tive of the image. All of the options for the tool are “live” meaning that you can change them and the tool will update. You can also use the 

Marquee as a selection tool to restrict painting and editing to within the marquee. Options for the Marquee tool include:

 Feather - Softens the edges of a selection.

 Opacity - Determines the opacity of the copied information.

 Heal - Determines how the copied information is blended into the original information: “Off” makes an exact copy of the selected

 area, “Luminance” maintains shading when moving elements so that they take on the shading of the original object to blend, “On”

 makes a copy of the selected area, then blends it with the surrounding values.

 Move Modes - Determine how the image is edited. Source changes the source area, and destination to changes the destination. 

• The Transformation tool allows you to scale, distort, rotate flip or flop a selected area (to correct lighting for example).

• The Stamp tool clones (makes a copy) from one area and paints it into another. Option (Mac)/Alt (Win) -click to set the Stamp source point, 

then release the modifier key and click and/or drag to clone.  Options for the Stamp tool are:

 Diameter - Determines the size of the brush.

 Hardness - Determines how hard the edge of the brush is.

 Opacity - Determines how transparent or opaque the copied information is.

 Heal - Determines how Vanishing Point blends the cloned information with the surrounding information.

• The Brush paints on an image with the same options as the Clone Stamp tool. In addition, a color swatch is provided for selecting a color 

to paint with. Notice that as you paint, the size of the brush changes in sync with the image perspective.

• The Eyedropper tool selects color from the image area for the Brush tool.

• The Hand and Zoom tool allow you to zoom in and out and pan. 

Vanishing Point Shortcuts

• Navigation and viewing

 Spacebar to temporarily access the hand tool 

 Command (Mac)/Control (Win)  + (+/-) to zoom in/out 

 Command (Mac)/Control (Win)  + 0 (zero) to fit in view 

 Command (Mac)/Control (Win)  + Z to undo 

 Command (Mac)/Control (Win)  + Spacebar to zoom in 

 Option (Mac)/Alt (Win) + Spacebar to zoom out

 Command (Mac)/Control (Win)  + D to deselect marquee selection 

 Command (Mac)/Control (Win)  + H to hide selection and surfaces

 Double click on the Hand tool to zoom to full view
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 Double click the zoom tool to view Actual Pixels (100% view).

 Holding down the X key temporarily zooms to 2x.

The Create Plane Tool 

 Command (Mac)/Control (Win) with a plane selected, selects the plane underneath it .

 Command (Mac)/Control (Win) + Period deletes last point set with the Plane Creation Tool.

 Backspace also deletes the last point created with the plane tool.

• The Marquee Tool

 Left,Right,Up,Down arrow keys to nudge selection 1 pixel at a time, adding the Shift key moves 10 pixels.

 Backspace or delete to delete a floating selection.

 Double click to expand the marquee to fill the editing plane.

 Command (Mac)/Control (Win) + C to copy, V to paste.

 Alt (Win)/Option (Mac) drag a selection to create a floating selection.

 Command +Opt (Mac)/Control+ Alt (Win) + T to create a floating selection

 Command +Opt (Mac)/Control+ Alt (Win) drag to tear off a floating selection of an existing floating selection or selection.

• Stamp and Brush tools

 [ or ] to decrease/increase brush size .

 Shift + [ or ] to decrease/increase brush hardness.

• Transform Tool

 Command (Mac)/Control (Win) + Shift + T to repeat the last duplicate and move operation.

• Other

 Command Z to undo.

 Command (Mac)/Control (Win) + Shift + Z to redo.

 Shift during drag operations constrains on and across multiple surfaces. 

Tips for using Vanishing point

• Use an obvious area in the image (such as a window) to create the perspective grid with the Create Plane tool, then drag the sides of the 

grid out to enlarge it if necessary.

• When creating adjacent planes, hold down the Command (Mac)/Control (Win) and drag off of an existing grid from an existing one rather 

than creating a new grid.

Image Warping (Edit > Transform > Warp)

Photoshop CS2 supports warping of pixels, vectors (both paths and shape layers), placed raster files and Smart Objects in 8,16 and 32 bit 

modes. 

• Warping can be intermixed with any other available transform commands since it is an extension of the Free Transform command. After 

selecting Edit > Free Transform, a new icon appears in the Options bar allowing you to toggle between Warp and Free Transform mode.

• When you select Edit > Transform > Warp, The Custom warp setting is selected by default. Sometimes it’s useful to choose one of the 

presets (the same presets that have been available for the text tool) as a starting point, then select Custom and fine tune from there. 

• While in Custom, you can drag the anchor points on the bounding box, drag the bounding box direction handles and/or drag anywhere 

inside of the bounding box to distort freely.

• Although it appears that you have to enter a numeric value in the Options bar for Bend, Horizontal and Vertical distortion, don’t forget 

that you can use “scrubby” sliders. Simply click and hold on the text next to the option that you want to change (Bend for example) and 

drag left to decrease the value and right to increase it. 

• The number of control points can’t be changed, but you can click and drag anywhere within the warp area to distort.

• When using Smart Objects, you can readjust the warp at any time by selecting Edit > Free Transform > Warp. The warp remains filly edit-

able; you will see the warp handles just as you left them. 
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• You can warp multiple layers at one time by converting them in to a Smart Object.

• You can not warp placed vector layers from Adobe Illustrator.

High Dynamic Range (32 Bit Per Channel Support)

HDR formats are currently being used in (and were built for) 3D and video production for special effects houses. You may have heard them 

being referred to as Open EXR or Cineon files. HDR Formats are especially useful in 3D rendering and advanced compositing (special effects, 

movies, etc.). It is also attracting a lot of attention from photographers. Because of this interest Adobe is introducing HDR in Photoshop CS2 

to allow users to test the water as well as to see what they might want in the future.

Background and History

• High Dynamic Range (HDR) gives you the ability to capture the entire range of tonal values in a scene. 

• Low Dynamic Range (LDR) images (those that most people are familiar with - 8 and 16 bit images in Photoshop) have a dynamic range 

of around 100:1, similar to the dynamic range of printed paper or a computer display. 

• HDR images are theoretically unlimited in dynamic range, but are typically on the order of 100,000: 1. This means that the values in an 

HDR image may go far beyond 1.0 (typically requiring floating point pixel representations). 

• In 8 and 16 bit, the maximum value for white is (255,255,255) defined as paper white or screen white. HDR has no maximum defined upper 

value. So HDR can differentiate between paper white and the white that occurs if you were to take a picture of the sun. 

• The other major difference is that 32 bit is floating point, it’s not limited to whole number values. In 8 bit there is no value available between 

255 and 254. In 32 bit you could define any value between those numbers you want. Imagine a dimly lit room, where no value would register 

as higher than 50% gray. In 8 and 16 bit, this means you’ve thrown out half of your color space resolution because those spaces only have 

values for certain colors and if those colors aren’t present in the image, you can’t redefine them and use them elsewhere. In 32 bit, you do 

have a fixed amount of colors you can define, but the colors themselves are not predefined, and so you get to use the entire range of the 

color space in every image. So not only is it a bigger color space to start with, it’s completely flexible as well. 

So, the idea behind HDR (32 bit), you’re really “super-sampling” virtually all of the values in the scene and then taking all of that data and custom 

defining your own algorithm to translate to 16 or 8 bit, which can be optimized by you for each image. 

Pitfalls

• Most monitors can’t accurately display 32 bit images.

• The human eye can’t really see that much information at one time (it can adapt across that range). 

• You can’t “fool” Photoshop into thinking that you’ve captured multiple images simply by processing a RAW file with different settings 

– you actually have to shoot multiple files.

• In order to print or do extensive editing (such as compositing, masking or painting) you must first convert the image to 8 or 16 bit.

Feature Implementation

HDR (32 bit imaging) is being introduced gradually (in much the same way that 16 bit was). Currently, the following functions are available 

in 32-bit mode:

• Crop (with rotation and resize), Image Size, Canvas Size and Trim

• Fill (except pattern fill) and Stroke (supported blend modes only) 

• Free Transform - including warping, 90 degree rotations, flips and arbitrary rotation

• Basic Blending (Edit > Fill using multiply mode for example)

• Blend Modes: Normal, Multiply, Difference, Lighten, Darken, Linear Dodge, Add 

• Clone Stamp and History Brush Tools (supported blend modes only) 

• Info palette (display of floating point values - no histogram palettes)

• Conversion of RGB to Grayscale, and Grayscale to RGB in 32 bits/channel 

• Conversion of 16 bit/channel images to 32 bit/channel (but no creating new 32 bit images)

• File formats: PSD, PSB, TIFF, LogLUV TIFF, Radiance HDR, PFM, OpenEXR 



�

• Filters: Average, Radial Blur, Fibers, Lens Flare, DeInterlace, NTSC Colors, Box Blur, Gaussian Blur, Motion Blur, Shape Blur, Add Noise, Unsharp 

Mask, High Pass, Offset 

• Save Selection, Load Selection 

• Adjustments: Channel Mixer, Photo Filter, Exposure

Note: ICC color management does not yet support HDR images. All 32 bit/channel images are linear (gamma 1.0), and it converts profiles to 

linear when doing bit depth conversions. Photoshop also converts the 32 bit images to the display profile as necessary. 

Merge to HDR

Merge to HDR is for combining multiple exposures of the same subject into a single 32-bit HDR file which can then be rendered down to 

produce a 16-bit or 8-bit per channel image. Merge to HDR and the 32 bit conversion methods are much more refined and controlled than 

cutting together multiple exposures. 

Tips for shooting exposures to be used with the Merge to HDR command:

• Merge to HDR requires at least 2 images, 1 stop apart. A minimum of three exposures works well, but more is typically better.

• Using images that are more than 1 stop apart results in posterized output.

• Start at slightly overexposed and step down until the image is almost completely dark.

• Using multiple outputs from the same Camera Raw image won’t work - you physically need to take more than one exposure.

• Shoot the scene on a tripod so that the exposures are aligned.

• Also, the scene must be essentially still, differences between images show up as blurs or ghosts in the final output 

• When using Adobe Camera Raw, you must turn off its auto settings.

• Images require either EXIF data for exposure or must be named as “name,1!2.ext” (the ! is being used as the fractional divider in the 

exposure time).

• Merge to HDR looks at the values in the workflow options when working with camera RAW. It pays attention to the size, but will always 

convert them to 8 bit images before combining them.

The Merge to HDR Settings:

• In Photoshop CS2 you can open the files that you want to merge and then select File > Automate > Merge to HDR (you can also add or 

delete images in this dialog). Or, in the Adobe Bridge, select the images desired and choose Tools > Photoshop Merge to HDR. 

• The Merge to HDR dialog box displays a filmstrip of thumbnails of your source images on the left, a preview of the “merged” image in the 

center, and a Bit Depth and Set White Point Preview slider on the right. In the Source area, you can deselected or re-selected individual 

exposures and preview the results. 

• Use the Bit Depth option to choose to open the image in 32, 16 or 8 bit depth. 

• Use the Set White Point Preview slider to set the point in the preview where brightness in the image equals white on screen (in 1 stop 

increments). As you move the slider to the left the preview image gets brighter, to the right, darker. This doesn’t change any of the actual 

values in the image, just the way in which they are displayed.

Previewing 32 Bit Images

To change the 32 bit preview, select View > 32 Bit Preview Options. It’s important to understand that as long as you are in 32 bit mode, you 

are only seeing a limited slice of the image’s entire value range. The toning controls are just there to allow you to pick which slice you want 

to see. 

Converting 32 bit images to lower bit depths 

You can convert a 32 bit image to 16 or 8 bit by selecting Image > Mode > 16 or 8 bit. In the HDR Conversion dialog you can choose from one 

of four Methods for the conversion:

• Exposure and Gamma - Exposure is simulating camera exposure time, so increasing it gives the effect of having taken a longer exposure. 

Gamma is literally the input to output ratio, which in practical terms can be thought of as the highlight to shadow ratio. Say the resulting 
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image from “Merge to HDR” looks under-exposed. You crank up the exposure until the highlights look good, but now the shadows are too 

light. So you increase the value of the gamma (by sliding it left) to darken the shadows, leaving the highlights untouched.

• Highlight Compression - It literally compresses the highlights. So if you take a 32-bit picture of the sun, this setting will compress the 

brightest areas in the image to paper white and scale the rest of the image values proportionately. This is more of a quick method to get 

something in the viewable range than something you use for creating 8 or 16 bit images.

• Equalize Histogram - Another quick method, not really suited for further use in Photoshop. It’s like Highlight Compression in that it drops 

white down to paper white bit it also scales the darkest dark to black. It’s a lot like the regular Image/Adjustments/Equalize command in 

that it moves the end points in so that the dynamic range is set between the darkest and lightest point in the Toning Curve. 

• Local Adaptation - This is the one that will typically give the best results. Initially you can ignore Radius and Threshold, the default values 

are generally fine and they make only small adjustments. In the Tone Curve and Histogram area, start by moving the endpoints in - you 

want the upper right one to be above the right-most edge of the histogram data and lower left endpoint to be below the left-most edge 

(you have now done what “equalize histogram” does automatically). Now evaluate your image; if the darks are too dark in some places 

(black where you want to see detail), click on the curve in the lower left to add a point and move the point up. If the brights are too bright, 

add a point in the upper right and drag it down. Clicking in the image area will show a ball on the curve indicating where that point’s value 

falls on the curve. It’s a lot like using the regular curves dialog but you have so much more range and image data that you can make more 

extreme adjustments without the image breaking down. When you’re finished making adjustments to the curve, use the Radius slider to 

set how many neighboring pixels are affected by the changes you make in curves - the curve is not just directly applied to the pixel values, 

it’s averaged across the target pixel and its neighboring pixels and radius defines how big the neighborhood is. Use the Threshold to define 

how much the neighbor is effected based on it’s value. 

Note: the Toning Curve and Histogram can be revealed for all of the Methods, but can only be adjusted in conjunction with the Local Adapta-

tion setting.

Enhanced Info Palette

• The Info palette now displays values in 8, 16, or 32 bit. To change the bit depth, click on the eyedropper icon (in the Info palette) and select 

the desired measurement from the list.

• In addition, the Info palette can display a variety of information that was previously only available in the status bar. To change the displayed 

status options on the Info palette, select the fly out and check the desired information that you wish to display. 

• The Info Palette has been expanded to show a “hint” for the currently selected tool. To hide the Hints, select the fly out menu on the Info 

palette and uncheck “Show Tool Hints”.

• Click and drag in the lower right of the Info palette to expand it.

Spot Healing Brush

If you’re a veteran Photoshop user, you might notice that when you first try using the Healing Brush (by Alt (Win)/Option (Mac) clicking in the 

image area), you receive an error message. Well, not really an error message, but a warning that “The Spot Healing Brush Tool automatically 

samples pixels to correct a spot with one step. To manually set the source, use the Healing Brush tool”. What’s going on? Well, the top tool in 

that group has changed - the Spot Healing Brush, rather than the original Healing Brush, is on top and the icons are very similar so it’s easy to 

miss this change. If you prefer to use the Healing Brush, simply click and hold on the Spot Healing Brush in the Tool bar and select it from the 

fly out. The tool you choose will then appear as the top level tool (until you select another tool from that grouping). 

The Spot Healing Brush will automatically sample data to clone from - you don’t need to Alt (Win)/Option (Mac) -click, simply paint over the 

area that you want to heal, and voila. For those of you that have used the Spot Healing Brush in Photoshop Elements 3.0, you might notice that 

the results you achieve in Photoshop CS2 are even better than those of Elements! The Spot Healing Brush analyzes the area around the tool 

as you use it and samples the “best” pixels to use for healing the clicked or painted area. In the Options bar, you can choose between using 

Proximity Match (which will analyze the surrounding areas to look for a good patch and Create Texture (which will create the replacement 

data by mixing data around the painted area).
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One-click Red Eye correction

The Red Eye Tool was designed especially for removing retinal flash reflection (red eye) with one click. Although some of you may have been 

using the more advanced Color Replacement tool, the Red Eye tool should make your lives easier with it’s simple yet powerful controls. In the 

Options bar, use the slider to select Pupil Size. This sets the proportion size of the pupil, or black center part, of the eye. Then set how dark you 

want the pupil with the Darken Amount slider. Then, click on (or near) the red portion of the eye (or click and drag around the eye) and the 

red eye is removed. Note that the Red Eye tool assumes that you will be sampling the eyes one at a time. You can get some erratic and often 

unflattering results by selecting both eyes at once.

Lens Correction (Filter > Distort)

Lens distortion artifacts are quite common in digital cameras and can be amplified when using wide angle lenses. The new Lens Correction 

filter corrects common problems caused by lenses such as pincushioning, barreling, perspective, rotation, and chromatic aberration distortions. 

Select Filter > Distort > Lens Correction to visually remove the distortion by simple inspection. First, lets take a look at the Tools:

• Remove Distortion - drag to remove distortion such as pincushioning and barreling by dragging in the image area.

• Straighten - drag a line anywhere in the image (usually a horizon) to straighten along the angle drawn.

• Move Grid - for repositioning the grid lines overlying the image to accommodate for individual differences in images.

• Hand and Zoom - for navigating images.

• Preview - for toggling between the original and corrected image.

• Show Grid - for toggling on and off the overlying grid.

• Size - to customize the size of the grid (to aid in the alignment of images).

• Color - to customize the color of the grid.

The Setting include:

• Remove Distortion - for removing the pincushioning or barreling distortion in an image. 

• Chromatic Aberration - compensating for imperfections in the image due prismatic behavior in the lens. The wider angle the lens, the 

more noticeable the color fringe. The Fix Red/Cyan Fringe slider modifies the pixels in the corresponding channels to better align them 

along the Red/Cyan continuum where as the Fix Blue Yellow Fringe slider modifies the pixels in the corresponding channels to better align 

them along the Blue to Yellow continuum.

• Vignette - either adds or removes (lightens or darkens) the edges of an image. Moving the Amount slider to the right makes the edges of 

the image lighter, moving it to the left, makes them darker. The Midpoint slider changes the diameter of the vignette - moving the slider 

to the left brings the midpoint in towards the center of the image, moving it to the right spreads the midpoint farther towards the edges 

of the images. 

• Set Lens Defaults - enables Distortion, Chromatic Aberration and Vignette settings to be saved based on camera model, lens model, and 

focal distance For the Set Lens Default to be enabled, the Lens Correction plug in must find EXIF data and that data must contain camera 

model, lens model, and focal distance. If any of those is missing, the option will be dimmed. Make the necessary changes to remove distor-

tion via the “Remove Distortion/Chromatic Aberration/Vignette” sliders and click the “Set Lens Default. This stores the information in a lens 

database. Multiple lens defaults can be saved for different camera model/lens model/ focal distance combinations for use on other images. 

When an another image is opened with the same lens/camera/focal distance combination selecting Lens Default from the Settings drop 

down menu will load and apply the lens default settings set for that specific combination. If there is no camera EXIF data in the image, then 

the Set Lens Default button will not be available. 

• Vertical Perspective, Horizontal Perspective and Angle  - help to remove distortions based on the angle of the camera to its subject. Use 

the sliders to make adjustments or enter an angle value.

• Edge - fills any empty area in the image using either Edge Extension, Transparency, or the Background Color.

• Scale - interpolates up or down an image as needed (primarily used to fill the image area after distortions are made).

Use the Fly out to Save, Load or Delete Current Settings. There are three primary difference between saving settings and Setting Lens Default; 
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“saving” settings saves all of the settings, not only the lens corrections, but also the transformations. You do not need to have EXIF data from 

the camera in order to save settings. Settings can be saved, shared, and loaded between computers and peers. 

Advanced Noise Reduction

The new Noise Reduction filter in Photoshop CS2 (Filter > Noise > Reduce Noise) allows you to expand the usable ISO range of your digital 

camera and maximize image quality by reducing the noise from camera sensors as well as film grain by discretely addressing the noise in 

individual color channels while preserving edge detail. It also reduces JPEG artifacts in JPEG images (eliminating the need for multiple shots 

to remove noise). This filter has both Basic and Advanced Settings: In Basic, you can eliminate noise using the following options:

• Strength - Amount of noise reduction (or, how much you want to soften the noise.) This setting works on the luminance information.

• Preserve Details - Controls how much detail you want to keep. This setting also works on the luminance channel.

• Reduce Color Noise - Focuses on the chroma channels in Lab (a and b).

• Sharpen Details - Controls how much sharpening is added to the image.

• Remove JPEG Artifacts - Removes those boxy JPEG artifacts evident when files are saved with low quality.

Clicking on the Advanced Settings displays the Per Channel tab where you can select an individual channel from the drop down menu. Strength 

and Preserve Details works as in Basics only they affect the selected channel as opposed to the Luminance channel.

Clicking the disk icon (with the downward pointing arrow) will allow you to save the settings which will then appear in the Settings drop 

down menu.

Smart Sharpen (Filter > Sharpen > Smart Sharpen)

Smart Sharpen improves the Unsharp Mask feature by offering more effective preservation of edge details and discrete advanced sharpening 

of shadows and highlights. Smart Sharpen also counteracts common kinds of blurring in images with slight blurs (i.e. lens blur, motion blur 

and Gaussian blur). To use this filter most accurately you will want to view your image at 100%. Select Filter > Sharpen > Smart Sharpen - this 

filter has both Basic and Advanced Settings. In Basic choose from the following options:

• Amount - use the slider to increase the amount of contrast that Photoshop adds where ever it detects an edge. It will make one side of 

the edge lighter and the other darker. This tricks your eye into thinking the image is sharper than it really is.

• Radius - use the slider to determine how many pixels are affected by the Amount slider. This will determine how thick the edge appears. 

As you increase the amount, if you notice a “halo” appearing around the edge areas, it’s a sign that the radius is too high. 

• Remove - select from one of three types of blurs. 

 Gaussian - Removes blurs that aren’t due to noise or motion. If your image doesn’t have a blur, set Remove to Gaussian. 

 Lens - Removes a blur caused by a lack of depth of field. Removing Lens Blur is more useful for the majority of shots (and does a  

 better job with edges and details).  

 Motion - Use the Angle slider to determine the angle of blur that you are removing. 

• More Accurate - For the highest quality (but longer rendering time), choose More Accurate.

Clicking the Advanced Mode button displays two additional tabs for control over Highlight and Shadow areas. 

• Fade Amount - fades back the amount of sharpening in the region.

• Tonal Width - determines the tonal region being affected (only the deep shadows or shadows and midtones).

• Radius - determines how many of the edge pixels are going to be affected by the fade.

Following are some advantages of Smart Sharpen over Unsharp Mask:

• Control - tonal range and incremental adjustments extending across a broader range.

• Power - the More Accurate option performs multiple iterations of the filter.

• Preservation - the edge detection in Smart Sharpen produces far less in the way of halos.

• Flexibility - the ability to target Gaussian Blur {effectively USM with the above advantages}, Lens Blur and Motion Blur.

• Workflow - the ability to save and load settings.
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• However, Unsharp Mask is still very fast, more familiar, and an embedded part of many workflows.

Image Processor

In order to make batch processing easier, the Image Processor script was created allowing you to save out multiple copies of the same file 

in different formats. This script can be run from either the Adobe Bridge or from Adobe Photoshop CS2. From the Bridge, select the desired 

images and then choose Tools > Photoshop > Image Processor. In Photoshop, select File > Scripts > Image Processor. If you use the Bridge to 

access Image Processor, then it will automatically run the script on the selected files in the Bridge. If you use Photoshop, you can choose to 

Use Open Images or Select a Folder of Images to process. Other options include:.

• Open first image to apply settings  - to process all of the selected files with the adjusted raw settings from the image that you open first. 

You will need to locate the file that you want to use as it does not automatically choose the first file in the folder that you have selected to 

process (reason being you might want to use a file in another location). Image Processor will process all of the images using those settings, 

but will not tag the original raw images with the adjusted changes. 

• File Type - select from JPEG, PSD, and TIFF. You can choose to save in a single or in multiple formats. If you want to resize the images, check 

the Resize to Fit option and enter the maximum (longest dimension) in height and width values. This is similar to the Fit Image command 

in Photoshop and is used when working with horizontal and vertical images simultaneously.  Each file type also has it’s own unique setting 

for saving files such as compression, quality and compatibility. 

•Preferences -  check the Run Action and select an action if you need to include additional modifications to each file (adding sharpening, 

making tonal and color corrections, etc.

• Copyright Info - choose to enter copyright information and save it as part of a file’s metadata.

• Include an ICC profile - to control if the image is tagged with an ICC profile.

Note: Image Processor automatically builds separate folders for each format selected and names them appropriately (TIFF, JPEG or PSD).

Exposure (Image > Adjustments > Exposure)

It is now easier than ever to make tonal adjustment to your images. Select Image > Adjustments > Exposure and use the following options:

• Exposure  - to simulate camera exposure time, (increasing it gives the effect of having taken a longer exposure). 

• Offset - to add or subtract a constant value from the image values.

• Gamma - to adjust the input to output ratio, which in practical terms can be thought of as the highlight to shadow ratio. 

Actions for Video Professionals

• Alpha Channel from Visible Layers - This action will create a standard alpha channel from all currently visible layers. Be certain to disable 

any background objects or title safe overlays that are not meant to be included in the flattened graphic.

Alpha Channel from Visible Layers (Inverted) - This action will create an inverted alpha channel from all currently visible layers. This is the 

type of alpha channel used by Avid nonlinear editing systems. Be certain to disable any background objects or title safe overlays that are 

not meant to be included in the flattened graphic.

• Broadcast-Safe Luminance - When preparing images for use in video, it is necessary to constrain the luminance range in order to comply 

with broadcasting standards. If the video signal exceeds a luminance value of 100 IRE in the NTSC environment or 700 mV in a PAL envi-

ronment, the graphic will cause technical difficulty. Likewise, if the black point falls below 7.5 IRE in the NTSC environment or 0 mV in a 

PAL environment, it is also considered an illegal value. By harnessing the power of a Levels Adjustment Layer, the proper luminance value 

can be achieved. This adjustment layer should be placed above all other layers in the composition. When enabled, the image will appear 

washed out. However, the full luminance range will be properly restored when the image is viewed on a video monitor. This action adjusts 

the image to have a broadcast-safe luminance range so it’s wise to perform any color correction or exposure enhancements first. Avid users 

should choose 601 levels when importing to their NLE.

• Broadcast-Safe Saturation - It is also necessary to constrain the saturation levels in images intended for broadcast. The NTSC-Safe filter 

can produce “clipping” on high-contrast images. This action produces a selection by using a “difference mask.” An adjustment layer is then 

applied to limit the saturation of the problem areas. If needed, you can refine the limiting effect of the adjustment layer.
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• Broadcast Safe - This action applies both the Broadcast Safe Saturation and Broadcast Safe Luminance adjustments.

• DVD Slideshow NTSC Standard - This action will size a photo properly for a DVD slideshow converting an image with square pixels to 

non-square pixels. Additionally, it will fit the entire image to the screen by letterboxing the image with black bars if the image is not the 

proper shape for the television screen. Use this action if authoring standard DVDs for use in NTSC devices.

• DVD Slideshow NTSC Widescreen - Use this action when authoring widescreen DVDs for use in NTSC devices.

• DVD Slideshow PAL Standard - Use this action when authoring standard DVDs for use in PAL devices.

• DVD Slideshow PAL Widescreen - Use this action when authoring widescreen DVDs for use in PAL devices.

• Interlace Flicker Removal - Since current television standards rely on interlacing for playback of video footage, there is an issue with some 

still images containing small detail when displayed on a monitor. Horizontal lines that are only 1 pixel/scan line high and have contrast with 

scan lines above and/or below them “flicker” when displayed on a monitor. For example, if you have a bright white horizontal line with a 

darker line above and below it, the white and dark lines alternate in being displayed during screen redraws. The solution to this has been 

to blur the entire image vertically 1 pixel. This softens high-contrast areas making them much less noticeable in the final result but also 

causes you to throw away detail throughout the entire image just to soften “strobing” in one area. This action attempts to only blur the areas 

of the image that are likely to cause interlace flicker rather than the whole image. To do this, the entire still is analyzed by duplicating the 

layer, offsetting it one pixel vertically, and changing the blend mode to “Difference”. This shows what areas are likely to strobe because the 

greater the difference between two adjacent scan lines, the more likely they are to cause this effect. Once this “difference mask” is created, it 

is turned into a selection, expanded slightly, and then a 1-pixel vertical blur is applied to the resulting area thus reducing (or in most cases 

eliminating) the flicker found in the original frame while leaving a bulk of the non-offending detail intact.

• Safe Title Overlay - This action will generate a Safe Title Overlay for use with any video sized graphic. It is an alternative to the safe guides 

generated in a new document when created from the preset list. This action can be applied to any Photoshop file allowing the designer 

to use guides for other purposes.


