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1) Variables
Variables, or Data-driven graphics make it possible to produce multiple versions of an image quickly and accurately. Let’s say, for example, that 

you need to produce 500 different Web banners or 200 different business cards based on the same template. In the past, you had to manually 

populate the template with data (images, text, and so on). With data-driven graphics, you can use a script referencing a database to gener-

ate the Web banners for you. In Photoshop CS3 you can automate this process with the Variables feature. Basically, you design a template in 

Photoshop, putting all of the elements that will change (the variable elements) on separate layers,  and then select layers in the template and 

assign them as variables. You can assign three different types of variables:

• Visibility variables let you show or hide the content of a layer.

• Pixel Replacement variables let you replace the pixels in the layer with pixels from another image file.

• Text Replacement variables let you replace a string of text in a type layer.

To define a variable in Photoshop, target the layer and select Image > Variables > Define. In the Variables dialog box, choose the desired layer, 

select the variable type and enter names for the variables. Note: Variable names must begin with a letter, underscore, or colon and cannot 

contain spaces or special characters (except for periods, hyphens, underscores, and colons). For Pixel Replacement variables, click Pixel Re-

placement Options, and choose a method for scaling the replacement image. If you are replacing pixels (photos for example) make sure that 

the images are in the same folder as the template. To define variables for an additional layer, choose a layer from the Layer pop-up menu and 

repeat the steps above.

After defining variables, you can manually input the data for each image, or import the data from a file into a data set. A data set is a collection 

of variables and associated data. To create a new set, select Image Variables > Data Set. Then, import the data that you need from an Excel 

spreadsheet, Filemaker database or any other source data that’s been exported as a comma- or tab-delimited file. Note: You must define at 

least one variable before you can edit the default data set. It’s important that if you are importing data from a file, the column name must 

match the name of the variable (exactly). To change a data set, simply select the data set you want to modify (from the drop down menu in 

the Variables dialog box), edit the data and click the Save Data Set button. To delete a data set, select the data set you want to delete, and click 

the Trash button.

Once you have imported data, you can preview the different graphics generated by the data sets by clicking the preview button and select-

ing the data set from the list. You can also use the next and previous triangles to navigate through the graphics. The data being displayed will 

change in the document window. 

To export Data Driven Graphics, select File > Export > Data Sets as Files. You can output individual images as PSD files from Photoshop to create 

an unlimited series of graphics for any use, dynamically generated, with no programming knowledge required. 
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2) Add a file name as a text layer script
This JavaScript (AddFileName20pt.jsx) adds the name of the document as a type layer within the document (without the extension). Just place 

the script in your Photoshop CS3/Presets/Scripts folder. A word of caution, it is doubtful that the script will add the type layer at the exact size 

and in the exact position that you will want it. In order to make changes to the type style (size, font, color etc.), it is CRITICAL (especially if you 

are recording the script as part of an action) that you double click on the “Filename” type layer in the Layers palette and make changes with 

the options bar. Do NOT swipe the text in the image area or it will record that file’s name as part of the action and all of the following images 

will be named the same as the first one that you recorded! Special thanks to Thomas Ruark at Adobe for creating this script.

3) Video
The reverse video script will take a video layer and reverse it in Photoshop! 

Place the script in Photoshop CS3 > Presets > Scripts. Open the video layer in Photoshop and, in the Animation (Timeline) palette set the 

work area to the length of the area that you need to be reversed. Make sure that the work area does not extend past the video layer’s 

extent (if it does, the script will try to copy from a frame which does not exist and the script will not work).  Select File > Scripts > Loop 

Video.  Special thanks to Mike Shaw at Adobe for creating this script!

Exporting a frame with transparency to use in another application

If you need to export a frame (or a series of frames) which have transparency to be used in another application (such as Adobe After Effects), 

create the necessary content/animation. There are a variety of ways to create transparency - layer and vector masks, not filling the image 

area with  a photo, using drop shadows with transparent backgrounds etc.. Once your file is set up as desired, choose File > Export > Render 

Video. For BMP, DIACOM, JPEG, PSD, PNG or Tiff, under File Options use Image Sequence and select the desired format. For Render Options, 

select the Straight Unmatted Alpha Channel. This will allow the other application to combine the file from Photoshop with transparency 

with any other image without any nasty halos around the edges.  Note: if you need to Export as a Targa file, under File Options, choose 

QuickTime Export: Image Sequence. Click Settings and choose TGA as the format.  Click Options and set to Millions of Colors. This enables 

the Render options where you can choose Alpha Channel - Straight Unmatted and Quick time will give you a Targa file with a straight 

unmatted alpha channel. If you don’t use the QuickTime option, you will see nasty, rough edges when compositing with other files.

4) Creating Droplets to use with Lightroom
You can think of Droplets as self running applications that trigger actions. First, use Photoshop to create the desired action. Then, to create 

the Droplet select File > Automate > Create Droplet. Click the Choose button to select where to save the droplet. In the Play area, select the 

Set and the Action desired. 

In the Source area, select the source files that you want to run the action on:

•Select “Override Action Open Commands” if you want any Open commands (recorded in the action) to be ignored.  If you include the 

open command as part of an action, Photoshop will open the SAME file each time the action is performed. Unless you want the same file 

modified over and over, deselect this option. Activating this option is handy if you need to open a specific file, such as a backdrop, which 

needs to be used with every image. 

• Select “Include All Subfolders” to process files in folders within the master folder you’re selecting. 

• Select “Suppress File Open Options Dialogs” if you want Photoshop to bypass  open dialog boxes such as the Camera Raw dialog box, 

opening Raw files with their default settings or with any setting applied to them.

• Select “Suppress Color Profile Warnings” to turn off display of color policy messages. 

Choose a destination for the processed files from the Destination menu.

• “None” leaves files open without saving changes (unless the action includes a Save command).  This gives you an opportunity to see the 

results of the action before saving the file.
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• “Save and Close” saves the files in their current location, OVERWRITING the original files.

• “Folder” saves the processed files to a folder in another location. If you select Folder, click Choose to specify the destination folder. 

Select  “Override Action Save In Commands” to ignore any save commands recorded in the action. 

If you chose “Folder” as the destination, specify a file-naming convention or add your own in the text entry fields. To begin a sequentially num-

bered list at any number, enter the desired number in the “Starting Serial #” box. Check the options for file compatibility (for Windows, Mac OS 

and Unix) when moving files cross-platform or utilizing on the web. 

Finally, select an option for error processing from the Errors pop-up menu:  “Stop for Errors” will suspend the process until you confirm the error 

message.  “Log Errors to File” will record each error in a file without stopping the process (you must check this and save the file before running 

the action). If errors are logged to a file, a message will appear after processing to notify you that errors had occurred. 

To use a Droplet, simply drag one or more files (or a folder of files) onto the Droplet. Droplets continue to reference the needed Actions inside 

Photoshop so don’t discard your actions after creating droplets for them! However, you can make changes to the Action and the Droplet will 

still work and will incorporate any changes made to the Action. 

To use the droplet with Lightroom, from the Library module, choose File Export. For Post-Processing choose Go To Export Actions Folder Now. 

Place the droplet into that folder. (Note: you might have to quit Lightroom and reopen it for the droplet to appear in the list). Next time you 

choose to export images, enter the desired options, select the droplet and after Lightroom processes the files, it will launch the droplet and 

run the action!

5) Selective Coloring in Photoshop
Sometimes you might want to set apart an object or subject in an image that might not stand out enough by itself. This selective coloring 

technique demonstrates the most flexible way to convert part of an image to grayscale while allowing selective area in the image remain in 

color. Note: this technique requires starting with a color image. 

• In order to make the image appear grayscale, add a Black and White adjustment layer.  (Select Layer > New Adjustment Layer > Black 

and White). In the Black and White dialog box, click on the auto option, select one of the presets or use the sliders to convert the image 

to grayscale. Note: although the image appears to change to grayscale, the Black and White adjustment layer is merely hiding the color 

in the original layer(s) below.

• The Black and White adjustment layer appears in the Layers palette. The icon on the left is the adjustment - double click on it to change 

the conversion. The icon on the right is the mask. By painting in the mask with black, you can hide the Black and White adjustment, reveal-

ing the original images underneath. To paint on the mask, from the tool palette, select a painting tool and choose black as the foreground 

color. Begin painting in the adjustment layer’s mask to reveal the color information from the original layer below.

• Continue painting with black until all of the areas that need to have color in them are revealed. If too much of the underlying color image 

is revealed accidently, change the foreground color to white and paint over the unwanted areas to hide the color. Painting with different 

shades of gray will also hide or reveal more or less of the adjustment layer.

If the color is too much (because you painted with black), with the layer mask targeted, select Image > Adjustments > Levels.  Drag the 

Black Output Levels sliders to the right (it will force black to a lighter shade of gray) until you reach the desired amount of color. 

• Variation: To lessen the Black and White adjustment layer’s effect and reveal varying degrees of color to the background, in the Layers 

palette, drag the Opacity slider down. As the opacity is decreased, the color from the underlying layer(s) shows through.

6) Posterizing Images
This technique demonstrates how to reduce the color palette of an image to crate a posterized effect with the most control possible. This 

unique approach not only allows for maximum flexibility, but also grants the power to customize not only where the levels break into different 

color, but also allows control over those colors.

• Add a Black and White adjustment layer by choosing Layer > New Adjustment Layer > Black and White. In the Black and White dialog box, 

click on the auto option, select one of the presets or use the sliders to convert the image to grayscale. Note: although the image appears 
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to change to grayscale, the Black and White adjustment layer is merely hiding the color in the underlying layers.

• To Posterize the image, select Layer > New Adjustment Layer > Posterize. In the New Layer dialog box, click OK and select the number 

of Levels (colors) to Posterize the file into. Note: if you posterize the image prior to taking it to grayscale you will get posterization per 

channel - which will give you three times the number of colors that you anticipate.

• If needed, you can refine the way the image is divided into the posterized shades of gray. On the Layers palette, double click on the 

thumbnail for the Black and White adjustment layer. Adjust the sliders to change where the image breaks the levels of posterization.

• To add color to the image, in the Layers palette, target the top layer and select Layer > New Adjustment Layer > Gradient Map. In the New 

Layer dialog box, click OK. In the Gradient Map dialog box, click in the gradient area to access the Gradient Editor.

• Create a custom gradient with the same numbers of color stops as posterization levels entered in the step above. Each color will be 

mapped to the posterized image depending on its placement in the gradient. Try assigning a darker color to the gradient stops on the 

left, and lighter ones for the stops towards the right. The advantage to using a gradient is that slight changes in the  location of the color 

midpoint or color stops will change the colors that are added to the posterized image making different color combinations easy to try as 

they are immediately updated in the image area. 

7) Sharpening Images
There are a variety of ways to sharpen images in Photoshop. In Photoshop CS2 we introduced Smart Sharpen which has more effective pres-

ervation of edge details and discrete advanced sharpening of shadows and highlights. Smart Sharpen counteracts common kinds of blurring 

in images with slight blurs (i.e. lens blur, motion blur and Gaussian blur). Some have referred to it as a “deblurring filter”. To use this filter most 

accurately you will want to view your image at 100%.

• Use the Amount slider to increase the amount of contrast that Photoshop adds where ever it detects an edge. It will make one side of 

the edge lighter and the other darker. This fools your eye into thinking the image is sharper than it really is.

• Use the Radius slider to determine how many pixels are adjusted (how thick the edge is). As you increase the amount, notice the “halo 

effect” appearing around the edge areas. If you can see this “halo” artifacting it’s a sign that the radius is too high. 

Note: The common values (amount and radius) in Smart Sharpen/Gaussian Blur when set to match those of Unsharp Mask (without threshold 

turned on) will indeed produce the same result.

Choose to remove one of three types of blurs:

• Gaussian - Removes blurs that aren’t due to noise or motion

• Lens - Removes a blur caused by a lack of depth of field. Removing “Lens Blur” is more useful for the majority of shots (and does a better 

job with edges and details). The lens option tends to be a bit slower than Unsharp Mask. 

• Motion - Use the Angle slider to determine the angle of blur that you are trying to remove

For the highest quality (but longer rendering time), choose “More Accurate”. 

Clicking the Advanced Mode button displays two additional tabs for additional control over Highlight and Shadow areas. 

• Fade Amount - Fades back the amount of sharpening in the region

• Tonal Width - Determines the tonal region being affected (only the deep shadows or shadows and midtones)

• Radius - How many of the edge pixels are going to be affected by the fade

The advantages of Smart Sharpen over Unsharp Mask:

• Control (tonal range and incremental adjustments extending across a broader range)

• Power (the “More Accurate” mode performs multiple iterations of the filter)

• Preservation (The edge detection in Smart Sharpen produces far less in the way of halos)

• Flexibility (The ability to target Gaussian Blur {effectively USM with the above advantages}, Lens Blur and Motion Blur)

• Workflow (the ability to save and load settings) 

• However, Unsharp Mask is still very fast, more familiar, and a large part of many people’s methodology and actions.
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An additional method for applying sharpening to images is using the High Pass Filter. Note: for the best results be sure that you are viewing 

your image at 100%. For the most flexibility, select the layer(s) to be sharpened and choose Layer > Smart Object > Convert to Smart Object. 

Select Filter > Other > High Pass. Ignore the “solarize” effect that it produces and click ok. Then on the Layers’s palette, double click on the icon 

to the right of the filter (the two triangles with lines). Change the Mode from Normal to Overlay and click OK. Then, in the Layers palette, double 

click the filter name (High Pass) to refine the Radius slider to achieve the desired sharpening effect. Note, to hide the sharpening from specific 

areas, on the Layers palette, click on the Layer Mask next to Smart Filters and paint with black to hide, white to reveal. 

8) The Pen Tool
The pen tool is the essential tool for selecting intricate hard edge objects with control and precision. But relatively few people know that after 

creating a path, the path can be stroked with many of the painting tools. For example, you can create a path and stroke it with paint, or dodge 

and burn along an object that would be impossible to draw freehand. 

• Create a path with the pen tool 

• Choose the tool that you want to use with the path and set it’s attributes.

• Then, from the Paths palette menu,  select Stroke Path. Choose the Simulate Pressure option to simulate pressure sensitivity of the tool. 

You can also use this technique to stroke with the Clone Stamp tool to eliminate objects that you don’t want.

9)  Animating a layer mask
With the enhanced animation palette in Photoshop CS3 extended, you can do so much more then ever before! This technique explains how 

to animate a layer mask by unlinking the  mask from the layer and repositioning it over time. Note: Although I will be using a type layer, this 

technique will work with any type of layer (pixel/photo, shape, adjustment etc.). 

• In the Layers palette click on the type layer to make it the active layer.  Use one of the selection tools in the tool box to select the area 

that is going to reveal the type in the animation. To make a spotlight effect, select a circular area with the elliptical marquee tool.

• Add a Feather. To soften the selection’s edges choose,  Select > Feather and enter a value in pixels. 

• Add  a layer mask. Click the mask icon on the bottom of the Layers palette to add a layer mask. The mask is automatically created from 

the selection, revealing the areas that were selected while hiding the areas that were not selected. In this example, the type remains vis-

ible where the initial selection was created.

• Break the link. The key to this tip is to break apart the mask from the layer. In the Layers palette, click on the link icon between the layer 

thumbnail and the layer mask thumbnail. The link icon disappears (or is hidden), allowing the  movement of the mask independently 

from the movement of the layer.

• Reposition the mask. Make suer that the layer mask is targeted in the layers palette and select the move tool from the  tool box. In the 

image area,  move the layer mask to its starting position (to the left of the type for example).

• Create the animation. In the Animation (Timeline) Palette you will see the type layer listed. Before changing anything, position the Current 

Time Indicator at the beginning of the animation (or where ever you want the animation to begin). Click on the triangle to the left of the 

type layer name to reveal the variable attributes. Next to the Layer Mask Position option, click the watch icon ( the Time Vary Stopwatch) 

to add a keyframe (this tells Photoshop to start the animation with the type hidden - because the mask was moved to the left, hiding the 

text). Reposition the Current Time Indicator to the time where you want the animation to end and click on the add keyframe icon (^)to 

add a keyframe for the Layer Mask position. Move the mask to the right of the type. 

• Play the animation. The mask should move from the left to the right of the image area, revealing the type as it is repositioned. 
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10 Type Shortcuts
There are so many shortcuts that can be used when working with type which will increase productivity. Here are a few of the ones that I use 

on a constant basis. 

• To set the type tool to other defaults, close all documents, then set up the options, and start editing. 

• If you reuse certain combinations of fonts, sizes, colors etc, select the options, then save them as a tool presets.

• Select the name of the current typeface in the Options Bar. Then cycle through the available fonts on your system with the up and down 

arrow.  Or, just type in the name of your favorite font.

•  Group text layers and hold down the Shift Key to change text styles over these different layers. 

• Hold down the Cmd (Mac) / Ctrl (Win) while typing point text. This will  let you reposition as well as scale the text on the layer, while the 

text is still active (to constrain the type proportions while scaling, add the shift key). 

• Double clicking on the “T” icon on Layers palette will select all of the type on the layer.

• For more Warping control of text, first convert it to a Smart Object.

• To commit the text, Cmd (Mac) / Ctrl (Win) + return or enter.

• Clicking the cursor within a type block will auto select the type layer on the Layers palette.

• Shift-click the Type tool to create a new type layer (in case you’re close to another type block and Photoshop tries to auto select it).

• While the type in the image is selected, Command (Mac) / Control (Win) + H will hide the selected “reversed out” type enabling a more 

accurate preview of the type (especially when looking at color!).

• Click in the text entry field on the Options bar to highlight the font name and use the up/down arrow keys on the keyboard to select 

the next/previous typeface.

• Using the fill shortcuts such as Option-Delete (Mac) / Alt-Backspace (Win) will fill type with the foreground color.

• Formatting Shortcuts:

Increase point size   Command (Mac) / Control (Win) + Shift + <

Decrease point size   Command (Mac) / Control (Win) + Shift + >

Increase baseline Shift  Option (Mac) / Alt (Win)  + Shift + up arrow

Decrease baseline Shift   Option (Mac) / Alt (Win)  + Shift + down arrow

Increase kerning/tracking  Option (Mac) / Alt (Win)  + left arrow

Decrease kerning/tracking  Option (Mac) / Alt (Win)  + right arrow

Align paragraph left, center, or right   Command (Mac) / Control (Win) + Shift + L, C, R

11) Adding Transparent overlays
The power of Layer Effects is the ease with which you can create common effects such as drop shadows and glows. However, you might want 

to put a more advanced spin on that effect. This technique shows you how to take this feature to the next level by separating the layer effect 

from the layer using advanced blending options. 

• Open the file that you need to add the overlay to. Select the type tool and click in the image area to add the necessary type. Note: this 

technique also works with any type of layer so you’re not limited to just type!

• In the Layers palette, double click on the name of the Type layer to access the Layer Style dialog box. Add the layer style that you desire.  

Note: checking the box next to the style will apply it, clicking on the name of the style will apply it as well as reveal it’s options. 

• While still in the Layer Styles dialog box,  remove the fill of the type by clicking on the Blending Options Default option. Under Advanced 

Blending, lower the Fill Opacity to zero and watch the fill melt away while the effect stay! Note: in the General Blending area, lowering the 

Opacity will lower both the fill and the effects.
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12) Creating Edge Effects
The great thing is that edges can be made from almost anything - you can try painting with black paint on a white piece of paper, use torn 

paper or create your own in Photoshop using textured brushes.

• If you paint on paper, scan the image and open the file in Photoshop. Note: It helps to know the final size of the image before you scan 

so you don’t end up having to rescan later because it was too small or wasting time working with a file that is larger than you need.

Select the Move tool, click on the edge file and drag and drop it into the other image .

• Reposition the Edge layer.  If the top layer of the other image wasn’t selected before dragging and dropping the edge file into the artwork, 

now is the time to reposition it. In the Layers palette, select the Edge layer and drag it to the top of the layer stack.

• Eliminating the black center.  If the center of the Edge image is black, set the Edge layer’s Blend Mode to Screen. This causes the  black 

area to be hidden, (revealing the image) and the white areas to remain white (hiding the image) creating the edge effect. Note, if you 

prefer the edges to be black, in the Layers palette, target the Edge layer and select Image > Adjust > Invert. This invert the edge making 

the white areas black and the black areas white. In the Layers palette,  set the edge layer’s Blend Mode to Multiply.


