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For all of the huge new powerful features that make up a new version of Photoshop, there are a many minor refinements and adjustments 

that you might miss if you’re not careful. You may never see these items in a demo, or on the back of the box, but they can make Photoshop 

far more efficient, saving you time and making you even more productive. 

I’m going to start with a feature that I now can’t live without - The Application Frame. Although it’s turned off by default, once I turned it on, 

there was no going back! In it’s simplest form, it hides the desktop while allowing me to view multiple images in tabs (a layout that would not 

be possible using any of the full screen modes - see below).  But that’s not all, the Application Frame also allows me to resize and reposition 

the entire application as one unit. This is very useful for example, if I have a large monitor and want the Photoshop to only take up a part of 

the screen, or if I want to reposition the application onto a secondary monitor. To invoke the Application Frame, select Window > Application 

Frame. Resize Photoshop by dragging the lower right corner and reposition by dragging the Application Bar (at the top) to reposition. 

This leads me directly to the second refinement - Opening Multiple Documents as Tabs. In my opinion, this is a much easier way to work 

with multiple images at one time. Instead of each image cascading down the monitor when opened, Photoshop CS4 defaults to opening them 

all in a single tabbed window. Simply click on a tab, to view the image. Use the new shortcut Cmd (Mac) / Ctrl  Win) + ~  to cycle through the 

images (this was changed to align Photoshop with the other Creative Suite applications) or use the traditional shortcut Cmd + Tab (adding 

the Shift key will reverse direction). If, you prefer the legacy “cascaded” view as your default, select Preferences > Interface and uncheck “Open 

Documents as Tabs”. To display cascading images with the Application Frame invoked, select Window > Arrange > Float in Window or Float 

All in Windows. If the Application Frame is not on, select Window > Arrange > Cascade. Or use the Arrange Documents icon on to toggle 

between floating and cascading but I’m getting ahead of myself here... However, before I move on, it’s important to note that when working 

with tabbed documents, moving a layer(s) from one document to another is done by via drag and drop (using the Move tool) from the image 

area (not the Layers panel). 

I’m sure that you’ve noticed several new icons directly below the menus in Photoshop. This new Application Bar is designed to help you 

quickly display images in a variety of ways. For example, you can choose to view “Extras” such as  Guides, Grids and Rules as well as change 

Zoom levels by entering a value or by selecting a percentage from the list. The Hand, Zoom and new Rotate View tools are also available as 

are the Arrange Documents and Screen Views icons (more on those features below). Toggle the Application Bar by choosing Window > Appli-

cation Bar. Note: the Application Frame must be off to toggle off the Application bar. With the Application Frame off, the Application Bar can be 

repositioned by dragging the grabber handle (on the left of the Application Bar) to the bottom of the monitor, a secondary monitor. To save 

screen real estate, the Application Bar will reduce in size if moved. 

OK, lets find out about the new tools on the Application Bar. The Rotate View tool rotates an image on screen without rotating the pixels in 

the document. If you remember using, hmmmm, what was it called, oh yeah, a pencil and paper... then this will make perfect sense! Remember 

how you rotated the paper on your desk in order to draw at different angles? Well, now you can do that on-screen with the Rotate tool! Even 

if this isn’t a feature that you’ve been asking for, you just have to try it. (If you have been asking for it, then I know that with one rotation, you’ll 

be hooked!) Just select the icon, then click and drag in the image area to rotate the view (remember, the pixels in the file are not rotated, just 

the view). See how much easier it is to draw and paint - and look, the rulers and guides rotate in tandem! For the numerically inclined, you 
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can enter a Rotation Angle (or use the Rotation Dial) in the Options bar and choose to Rotate All Widows if appropriate. When finished, click 

Reset View to set the rotation to 0˚. 

Also on the Application Bar, is the Arrange Document icon. This is a fast and flexible way to display multiple documents at once. The first row 

of icons will “Consolidate All” open documents in Tabs and “Tile all Images in  Grid” or “Tile All Images Horizontally or Vertically”. The second 

set of icons become available as multiple images are opened to provide a variety of layouts (from 1-6 images). In addition, instead of having 

to go to the Window > Arrange menu to search for display options, you can use the Arrange Document icon to choose to Float all Windows, 

Create a New Window (not a new file, but a secondary view of a single file), zoom to Actual Pixels and Fit on Screen and choose to Match Zoom, 

Mach Location and Match Zoom and Location. Note: when working with multiple images, use the Zoom All Windows or Scroll All Windows (in the 

Options bar) to zoom and pan all images in tandem (holding the Shift key temporarily toggles these options).

Because the Application Bar is committed to making it easier to view images in different manners, it made sense to relocate the toggle 

between Screen Modes icon. If you’re upgrading for Photoshop CS3, you will notice that we are now back to only 3 screen modes - as the 

new Application Frame replaces the need for Maximized Screen Mode. Which reminds me of another subtle refinement -  when you enter full 

screen mode, your panels are automatically hidden so that you don’t have to remember to tap the tab key if you want to present your image 

on a black screen. To customize the background color and the border around the image (Line, Drop Shadow, or None) of the Screen Modes 

choose in Preferences > Interface.

On the right side of the Application bar is the Workspace Picker - designed to help you move quickly between different workspaces. At the 

top of the list you will see any custom workspaces that you have saved as well as the default workspaces that ship with Photoshop CS4. Simply 

click to select the desired workspace from the list. Note try selecting the ” What’s new in CS4” workspace - it will highlight all of the menu items 

in Photoshop CS4 that have been modified! Panels can now be distributed to multiple monitors and saved as workspaces.  

In Photoshop CS4, we’ve changed the way that you close Panels - right mouse click (Ctrl-click on Mac with a one button mouse) on the tab 

and select Close or Close Tab Group.  If you pull a panel out of it’s tabbed group and float it freely, then a close button (x) appears. If you tap 

the Tab key (to hide the panels), they will be displayed if you position your cursor at the edge of the monitor (like a roll-over). To toggle off this 

feature, choose Preferences > Interface > Auto-Show Hidden Panels. To free up more screen real estate in Photoshop CS3, we introduced col-

lapsible “iconic” panels. However, they remained open after clicking on them. Now, in Photoshop CS4, you can choose to collapse the panels  

automatically by right clicking on the panel tab, or by selecting the Preferences > Interface > Auto-Collapse Iconic Panels. Basically, you show 

the panel (by clicking on the icon), pick you options, and when you click anywhere outside of the panel, it will automatically collapse. And, 

although this is not anew feature, I thought it was worth a mention - the Tool bar can be relocated and even “docked” to the panels on the right 

side of the screen. Simply drag it by the grabber handle - when you see the solid blue line next to your panels on the right, release the cursor 

to “dock” the panel. Or, if you prefer, you can move any of the panels to the left side and dock then with the tool box. You can also relocate the 

Options bar for example you may want it at the bottom of the monitor or on a secondary monitor.

• Next lets talk about the new features that will help you to zoom in and work with large files. Photoshop CS4 can display images much faster 

depending on the system’s hardware-accelerated display and Open GL capabilities. In addition, the on screen jaggies that you use to see 

at uneven zoom levels like 33.3% are now rendered smooth. If you zoom in above 600%, a new Pixel Grid is displayed on top of the image 

(toggle Pixel View under View > Show Pixel Grid). A new, quick way to move to another part of the image is with the new Birds-Eye View - 

select any tool, hold down the “H” key (to temporarily select the Hand tool) to “crash”-zoom in on an area. Reposition the rectangle to zoom 

in to another area, and release the Hand tool to zoom in on that area. We also support Flick Panning while using the Hand tool to move left, 

right, up or down in an image (click, drag and hold for legacy behavior). If you’re looking to control zooming behaviors, be sure to check the 

Preferences > General for:

• Animated Zoom (requires Open GL Drawing) 

• Zoomed Click Point to Center (centers the location of the cursor click point to the center of the screen)

• Enable Flick Panning -  (requires Open GL)

Photoshop Cs4 also supports the multi-touch trackpad gestures on portable Macs such as pinch, swipe, rotate, zoom, and scroll.
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Moving on to the tools, I am so excited to tell you about the new Spring loaded cursors. In previous version, if you wanted to quickly use 

a tool - you would have to switch to that too, use it and then switch back. Now, with one tool selected, use the shortcut for another tool 

(continue holding it) and when you release the shortcut, the tool returns back to the originally selected tool. For example, lets say you have 

the Move tool selected. You need to use the Marquee tool so you press and hold the “M” key, use the marquee and when you release the “M” 

key, you are back with the Move tool! This works exceptionally well with the new Rotate View tool. For example, if you’re drawing a path and 

want to rotate the view, press and hold the “R” key, click and drag to rotate the view, and when you release the “R” key, voila, you are back to 

the Pen tool ready to continue your path.

Additional tools that have been refined include the Eyedropper (Color Sampler, Ruler, Note and Count tools) which have been relocated to 

the first grouping of tools on the tool box. In the Options bar, the Eyedropper reveals the option to Sample All Layers (as oppose to just the 

selected layer as in previous versions). Clicking the Note tool, displays the new Note panel designed to keep your comments (notes) organized. 

The Dodge and Burn tools have been improved not only allowing better control in the shadows and highlights but also the ability to protect 

tones so that images maintain more detail when lightening and darkening regions. The Sponge tool has the option to harness the power of 

the new vibrancy adjustment layer. And when using the Clone and Heal tools, the source area can be overlayed as before, however now it 

can be limited to the brush size by checking the “Clipped” option on the Clone Stamp panel. If you prefer to leave the overlay off by default, 

Option (Mac) / Alt (Win) + Shift will temporarily display the overlay.  

If you’re tired of tapping the left and right brackets to increase / decrease your brush size, try using the new Drag-resize brush cursor key-

board shortcut to make rapid changes to the brush size. Ctrl + Option (Mac) /alt right click (win) -drag will increase/decrease brush size and 

displays a red overlay of the density and feather of the brush for visual reference. Add the Cmd (Mac) /shift (Win) to change hardness. Note: 

the preview color can be controlled in Preferences > Cursors > Brush Preview). 

And while we’re on the topic of keyboard shortcuts, we know that changing them can be painful, but certain shortcuts “had” to change in 

PSCS4. Some changes were made to bring Photoshop in alignment with the other creative suite applications, for example, Cmd (Mac / Ctrl 

(Win) + 1 sets the zoom level to 100% brings PSCS4 into alignment with Illustrator, InDesign, and Flash). Other shortcuts changed when we 

simplified the way that adjustments worked by taking them out of modal dialog boxes and putting them into panels. Because a modal dialog 

box is it’s own little world, it can use shortcuts that are already used in Photoshop “proper”.  However, when we put adjustments like Curves, 

Levels, etc in the Adjustment panel, we no longer have that isolated context. As a result:

• Displaying a single channel in Photoshop was previously assigned to Cmd (Mac) / Ctrl (Win) +1, 2, 3, etc. Cmd-1 would show Red, Cmd-2 

would show Green, etc.  Those shortcuts, along with the shortcut for showing the composite channel, have now shifted two places to the 

right.  Therefore Cmd-2 shows the composite, Cmd-3 shows Red, Cmd-4 shows Green, etc. 

• Previously, when targeting a channel in a modal dialog box (such as Curves, Levels, etc.), you used Cmd (Mac) / Ctrl (Win) +1, 2, 3, etc.  Cmd-1 

would target Red, Cmd-2 would show Green, etc.  Just like the shortcuts for displaying channels, those shortcuts have all shifted two places 

to the right.  When using the panel-based adjustments, the shortcuts have changed to Opt (Mac) / Alt (Win) +1, 2, 3, etc.  

• The Hue/Saturation and Selective Color commands are slightly different as they don’t map to just RGB/CMYK, but the same general rules 

apply: Opt-2 selects the Master channel, and Opt-3, 4, etc. select the subsequent items in the list.

• To load luminosity as a selection, use Cmd-Opt-2.

• When you’re using the Move tool, the contextual menu shows you a list of the layers that contain visible pixels under your cursor.  To get 

that same list while using another tool, normally you’d hold down Cmd-Ctrl (Mac)/Ctrl-right click (Windows).  That combo is now taken for 

drag-resizing of brushes, as mentioned above.  So, you can now get the same menu either by holding V (to get the Move tool temporarily) 

and hitting Ctrl (Mac)/right click (Win), or you can hold Opt-Ctrl (Mac)/Alt-right click (Win). 

• Tapping \ (backslash) cycles between normal view & displaying the mask on a layer.  Holding backslash, however, displays a temporary 

preview of the unadjusted state of a document.  (It’s like unchecking the Preview checkbox temporarily.)  Because of the need to distin-

guish a tap from a hold, there’s a slight delay before the results of the hold behavior become visible.
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 File Info is now a Flash-based panel giving developers the ability to extend it’s capabilities. As in previous versions, you can view and (in most 

cases) add metadata information to all panels. If your monitor isn’t large enough to see all of the categories, use the arrow to scroll through 

the panels, or use the drop down menu in the upper right to select a specific panel. Drag and drop the panel’s tab to rearrange their order. 

Clicking on the Import button will allow for importing, exporting (or saving) templates. By default it will save them in the templates folder 

(which can be displayed) so that they may be shared across  Adobe applications. 

And it’s not only the File Info panel that is Flash based - developers now can build their own panels to accomplish customized tasks. For example, 

if you select Window > Extension > Kuler and /or Connections to display those custom panels within Photoshop!

Whew, well before I wrap this up, I just want to mention a few more additions and refinements:

• Bridge and Photoshop now both use/shared Camera Raw  preferences (as opposed to Photoshop and Bridge having their separate 

preferences). Now when changing the preferences in Bridge they will also be modified in Photoshop and visa versa.  

• Mac OS10.5 provides support for 16-bit printing for increased color depth and clarity with printers that support 16 bit. In addition, the 

limit of 30,000 pixels has been lifted for those that need to print very large images. And, some printers will now display the dimensions 

in the Print dialog box and preview gamut warning.

• The Save for Web dialog has been improved to control metadata export options and convert to sRGB right with in the dialog. 

• To help designers create images that convey meaning for teh widest audience possible, PSCS4 can soft proof for both Protanopia and 

Deuteranopia type color blindness using  using built-in Color Universal Design Organization profiles. Note: these profiles are available in 

both Adobe Illustrator and Photoshop.

• The default Stroke color in Layer Effects is now black!

• If you are doing video work, you can now use single-key shortcuts for moving among frames by toggling the “Enable Timeline Shortcut 

Keys” command that lives in the Animation panel fly-out menu.

• Two new scripts are available to quickly work with complex multi layer documents: Flatten All Layer Effects and Flatten All masks

• You can go directly to the Photoshop product age where you can look at all of the additional Filters and plug-ins that are available for 

Photoshop by choosing Filter > Browse Filters online.


